Print keeps stopping

Capture
Hi there.
Just started into the laser hobby, but have a problem.
I have been trying to run test cards for the laser, but it will not finish any of them.
I have copied the text from the screen, which seems to be fault codes.
Can anyone tell me what the problem is?
Apologies if it’s really simple.

Paul

The question mark symbols show that there are transmission errors. The most common cause is a low quality USB cable. Try to change the cable for a high-quality one. Next, you can also try different USB ports. Then you should also make sure that you don’t have disturbance on your power lines close to the laser (like vacuum cleaner in the same outlet).

Thanks for the reply.
I will try those tomorrow.

Hi Melvin.

I have tried 3 different USB cables, with very little effect.

All other COM ports.

Power wise, I have tried different sockets, and no other equipment anywhere close.

Someone mentioned reflashing the Firmware?

Have you clicked ‘Show All’, and run it again?
I found that mine would stop randomly because the Fire-sensor would trigger - I think this was down to me having the garage door open and the UV from the sunlight triggering it.
My current issue is the movement sensor tripping it - But ‘Show All’ will give you a bit more info.

Thanks for the reply Colin.
I’m guessing that this will give me more detail instead of just the symbols?

It should do, as you’ll be seeing exactly what error codes are being passed back from the machine, which at the very least will give you a research point to figure out whats stopping the machine.

Check that the laser is bonded and grounded. Static build-up on the machine’s chassis can make you drop connection, reboot the laser, fail mid job, etc.

If you select “show all” it won’t change anything in the case you have that question mark symbols in the transmission. These are just corrupt bytes.
For some users, grounding (as Richard suggested) was the solution. Some others reported that upgrading the firmware did the trick. I have a guide how to do it here: Firmware Update & Settings - Diode Laser Wiki But I also had some rare cases where the board was just broken and a replacement was the solution. Sculpfun support is very helpful in such cases.

Thanks for the replies.
Just tried running a test card with the “Show All” checked.
Sure enough it stopped.
These are the error points.
Anything look out of place?
By the way, I ran the same test this morning with no issues???
This is taking some trial and tracking.

The static problem I had was intermittent with no real rhyme or reason when it would fail .