Print to print driver not working

I am trying Lightburn with my GCC LaserPro Explorer, which uses the 32-bit GCC printer driver running in Windows 7 (a VMWare image). I select Print (keep colors) and then click the Preferences button. First problem is that the resulting print dialog is missing all of the text and most of the controls! I then cancel that and select a different printer and then again select the LaserPro and then when I click the Preferences button, the dialog load successfully and I’m able to set the preferences (e.g., power, speed, etc.) and confirm the dialog. Then I click Print, but the job doesn’t get sent to the laser and I see an “Error - Printing” status in the printer job queue. The GCC printer driver works fine from CorelDRAW and in the past I’ve used it successfully with other programs. Troubleshooting suggestions appreciated.

Making some progress. I restarted everything and now the job gets sent to the laser, but when I run the job, the position is wrong on both axes, and it also seems to ignore the preference settings (e.g., it runs as a raster engraving at 50% power and 50% speed, which is the default setting in my laser firmware, rather then a vector job at 100% power and 2% speed, which is what I set in the preference dialog). Also, the next time I print, the preferences returns to the default settings - with CorelDRAW it retains the most recent settings. As for the position, the X axis seems offset and the Y axis inverted and offset (I had to move the drawing into negative Y above the grid in the software to get a job that the laser could run).
So, it seems that there are at least two issues: the position offset/axis inversion and the print driver (running in LightBurn) ignoring/forgetting the preferences setting. Suggestions?

LB outputs 1 pixel lines for vector shapes. I am pretty sure you are seeing raster engraving of vector shapes because GCC wants to see “hairline” from CorelDraw or 0.001" from a program like AI. I have a Universal Laser Systems VLS6.60, and vector output from LB print driver also engraves. A workaround I found is if I print to PDF from LB using the Microsoft PDF driver, and then open the PDF file and select the Universal Laser Driver, the vector lines convert correctly.

Thanks for the suggestion. However, I turned off raster engraving in the print preferences dialog, so I think if the printer driver were working correctly in LightBurn, it wouldn’t be raster engraving, even if the line width was wrong - it would just run the job and nothing would happen. I think the main problem is that the preferences settings are being ignored.

When I exported the job from LightBurn as DXF and then imported that file into CorelDRAW, it came in as “hairline”. When I import from other DXF files with thicker line widths created in other software into CorelDRAW, they do not import as “hairline”. This implies that the line width being output by LightBurn should thin enough to be interpreted by my driver as vector lines. According to my laser’s manual, by default (unless overridden in the firmware prefs), lines of thickness up to 0.1mm (0.004") will be cut in vector mode.

LB outputs 1 pixel lines, which converts to 0.010" at 96PPI and 0.013" at 72PPI. When LB outputs DXF, it ignores line width when opened in a CAD program like AutoCAD, and AutoCAD wrote the DXF standard. You are correct - it is “hairline” in Coreldraw. Not sure why. But, when LB exports to AI, AI imports line width at 0.013".

I think it has more to do with LB outputting 1 pixel line width. That is too thick to be interpreted correctly by my Universal Laser Systems print driver.

OK, thanks for that info. I was hoping that LB’s recently added printer driver support would allow me to send jobs directly to the laser from within LB, but it looks like that doesn’t work with my driver (maybe that functionality is just still buggy), and based on what you’re saying, even if it did basically work, I’d still have the line width issue. Seems like FB should add a fractional pixel line width option.
Unfortunately, even if I output to a PDF file and print from there, which could presumably work around both the line width issue and the ignored preference settings issue, I still have the problem of the position offset and inverted Y axis. I’ll experiment tomorrow to try to figure out a workaround for that. If I can automate it, then it might be worth it. Otherwise, I’ll stick with CorelDRAW for now.
BTW, one of the main reasons why I wanted to be able to use LB is for the camera functionality. I don’t know if using that feature would be practical with a workaround like the one you suggest, although I don’t see why it wouldn’t.

Not having much luck. Win7 doesn’t have the Microsoft PDF driver. I’ve tried CutePDF and doPDF and I get a similar output PDF in which the drawing is offset in both X and Y. When I try sending that job to the laser from Adobe Reader, it seems to send it but it never gets to the laser.

I did try to cut from Inkscape and I found that it also only works in raster mode. I think I used the Win32 vector cutting extension in the past, but that has stopped working in recent versions. However, with Inkscape the print dialog and preferences otherwise worked fine, I was able to engrave in raster mode, and there was no problem with the drawing being offset in X or Y, so the print dialog and offset problems seem like bugs in the LightBurn print functionality.

Has anyone successfully used the LightBurn print functionality in Windows 7 32-bit?