Problem connecting to lightburn recently

I have had no issue connecting to lightburn for over a year now, but recently I have not been able to. In the laser window it shows as busy and won’t let me do anything. For some reason ever since I’ve had it, it won’t connect to lightburn immediately when I open lightburn or turn on the laser… I have always had to turn it off and back on again, and it would work fine after that. Now when I turn it on it says “ready” but in console it says “awaiting connection”. This is normally were I turn it off and back on and it would work fine but now when I do that, it will either say “busy” and the console will say “port failed to open. already in use?” or it will continue to say “ready” but gave me all this when I tried to reselect the device:





entry 0x400806a8

[MSG:X Axis Standard Stepper Step:I2SO(1) Dir:I2SO(2) Disable:I2SO(0) Limits(0.000,410.000)]

[MSG:Y Axis Standard Stepper Step:I2SO(5) Dir:I2SO(6) Disable:I2SO(0) Limits(0.000,400.000)]

[MSG:Laser spindle on Pin:GPIO(22), Enbl:None, Freq:1000Hz, Res:16bits Laser mode:On]

[MSG:X Axis limit switch on pin GPIO(36)]

[MSG:Y Axis limit switch on pin GPIO(35)]

Grbl 1.1h [‘$’ for help]
I have a Goldley A5 M50, 5w diode. It’s generic but as you can probably tell by the name, it’s almost identical to atomstack and actually has an atomstack laser module. I tried reinstalling an older version of lightburn but that didn’t help. It connects to laserGRBL just fine… and I can use it with the controller just fine. But for some reason I can’t get it to connect to lightburn at all now. Running windows 10 with 32g of ram. Should I try to flash the firmware? I didn’t want to mess anything up when it seemed to just be a lightburn connection issue… I’m loosing my mind trying to run a business and can’t figure out how to fix this. Someone please help!

Check to make sure the device profile is set to the correct device type.

-Click “Devices” in the “Laser” window
-Double click your laser in the list
-Change the selected device to “GRBL” if it is not already
-Click next until you’re done
-Be sure to click “OK” to exit the Devices window and save the changes (“X-ing” out will not save the changes)

If that doesn’t help, check to see what baud rate LaserGRBL is using to connect to your device, and set the Baud Rate in the Device Settings window (Edit > Device Settings) to match that. You can also try changing the Transfer Mode from “Buffered” to “Synchronous”.

Thanks for the reply. I’ve tried everything in the first part of your message but tried it again in that order just to make sure… the baud rate laserGRBL is using is the same as lightburn; 115,200… My transfer mode was origanlly set to buffered but I switched it to synchronous and it is still doing the same thing. It still says “busy” and is giving me this in the console:
Port failed to open - already in use?

[MSG:Check limits]

[MSG:‘$H’|‘$X’ to unlock]

Grbl 1.1h [‘$’ for help]

[MSG:Check limits]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

Does this laser have limit switches? If not, make sure to disable “Auto-home on startup” in the “Device Settings” window in LightBurn (“Edit” > “Device Settings”).

After the “Caution: Unlocked” message, are you able to jog and otherwise operate the machine? That message suggests your machine should be in a ready state - does it lock up again if you try to jog it, and, if so, what do the messages day at that point?

Please also enter the following in the Console window:


And then paste the response here.

Make sure you have lasergrbl closed.

I guess you could call them “homing limit switches”… only on the left and the front. Not on the back or right… But I usually have auto-home off… it’s done this with it set to on as well as off…

After “Caution: Unlocked” it still says “busy” in the status bar, at 100%, but never changes. And I can click on the directional buttons and “stop” and they do nothing.

Also, are you hitting the enter key after each of those commands? As in “$i” [enter] “$$” [enter] etc? Because I typed it that way and there was no response… It doesn’t seem to be responding to anything, unless I’m not doing it right…

Make sure sleep mode is not enabled for your USB.

Yes, you should be getting a response from those commands. Is LaserGRBL closed when you attempt to connect with LightBurn? I wouldn’t expect you to see any kind of response from the controller at all if LaserGRBL were connected, but it’s worth making sure it’s not interfering.

Another thing to try: under Edit > Device Settings try toggling ON “Enable DTR Signal” if it is currently disabled, or toggling it OFF if it is currently enabled.

I did. I don’t even use laserGRBL, I just opened it once this started happening to see if it worked in that program and it did…

I did that also…

Yes, laserGRBL is closed. I normally never even use it. I even checked the processes in task manager to make sure…

WAIT! The DTR signal worked!!! It was disabled, and I enabled it, and nothing happened. So, I restarted lightburn and the console read:

Waiting for connection…




Target buffer size found

I restarted it again just to make sure, and it’s working now! Thank you so much!!! I’m going to reinstall the latest version and make sure it still works but I don’t see why it wouldn’t… I’m still somewhat confused because I’m pretty sure I’ve always had that disabled, but I could be wrong. Either way, thanks again!

1 Like

It’s working on the new version also! Cheers!!

This topic was automatically closed after 30 days. New replies are no longer allowed.