Problem connecting to Marlin

I am having trouble connecting to my Marlin (latest stable marlin) laser. When I go to detect it, lightburn sees it as GRBL-M3 1.1e. If I accept this, I can move x and y but home and get coordinates don’t work. This is the case at 115,200 as well as 250,000 (the machine being the later). I tried the other two versions of GRBL with the same results. I also tried Marlin but couldn’t get past “Waiting for connection”. Pronterface works perfectly, including homing.

Any ideas?

[EDIT] I figured out that if I connect in pronterface, disconnect, and then open LightBurn then Marlin works, home works, etc. It seems some other people have run into this bug. Any ETA on fixing it?

How do you move x and y? Are you using the Move window in LightBurn?

If your laser engraver is a Marlin device, I would suggest creating the device manually and selecting Marlin instead of GRBL-M3.

I would be interested to read what messages appear in the Console window in LightBurn under both conditions.

If you run Pronterface first does LightBurn find the Device as a Grbl-M3 device or as a Marlin device?

Scenario: Laser cutter on, fresh windows reboot, I start Lightburn with it set to Marlin. I get the error “Waiting for connection…” and nothing else. I close Lightburn. Then I start Pronterface, connect, disconnect, and open Lightburn. Everything works correctly. If I close Lightburn and reopen it, it doesn’t work…needs a fresh Pronterface ?handshake? each time.

Side note: The GRBL options won’t work even if homing did; they don’t do M3/M5 for the laser.

More info: Connection is lost about 30 seconds into a job. Machine just stops moving, but laser stays on!

This is a very interesting project.

When it comes to ‘bug’ and ‘fixing it’ we’re going to have to explicitly define what’s happening for the devs to go forward with that. I don’t have enough information to post a bug report yet - there’s a few more things we can do in the interests of getting this up and running.

Is your Octopus board this one:

I see the 115,200 and 250,000 baud rates so my understanding is that you’re connecting via USB. Is your cable new, short, shielded and does it have the ferrite noise suppression beads on each end? Those details can all aid communication woes. I’m not saying it’s a bad cable because having a bad cable doesn’t align with all symptoms. I am suggesting that troubleshooting can be confounded by a cable that works almost all the time.

I’ve seen random disconnects on at least a half-dozen popular production built machines when the power supply would brown-out and crash the controller. You’ve gotten this far so I don’t think this is the problem but I do think that a sweep-meter or DVM may be too slow to verify power supply stability. Do you have a logging oscilloscope?

In the Console window in LightBurn there’s a ‘Show All’ switch on the far right.
Turn that switch on and communicate with your device. Execute commands until it gets lost and copy and paste the contents of that window into a txt file and attach it in a reply here.

There are so many variables with a homebuilt machine, there isn’t a known troubleshooting path but i’ll help where i can.

Yes, that is the Octopus board. Here is the github for it: GitHub - bigtreetech/BIGTREETECH-OCTOPUS-V1.0: This is Octopus open source material

The cable admittedly is a bit of a mess. It has one USB cable going from the board to the chassis, and then another cable plugs into that and goes to the computer. It’s all buried behind my desk but I think there may be a USB 3.0 extension cable in the chain too. So I pulled that all out and ran a brand new cable direct from the board to the PC with the same results. Still, Pronterface works perfect either way. Maybe I should try dropping the bandwidth in half?

I do not have a scope unless you count my arduino. Power supply is a MeanWell with plenty of cooling and is rated at more than 2x what the maximum load should be.

I appreciate the help; have countless hours and dollars into this machine and would hate to need to go back to Ruida.

connection lost.txt (3.8 KB)
connection lost (new cable).txt (22.5 KB)
waiting for connection.txt (61 Bytes)

I tried cutting the bandwidth in half and it stopped dropping connections. Can’t remember the last time I used 115200 with anything more complex than a keypad…this was with a brand-new 5-star rated cable direct between the board and the computer and it still made a difference. I still had to use Pronterface to ‘prepare’ the connection. The dropouts seem to be gone. The strange connection issue seems to remain. Of course now there’s a new issue

I think I found the cause of the issue with the connected letters. For G0 moves the command is something like “G0 X10 Y20 F0” the ‘F0’ should be an ‘S0’ so the command would be “G0 X10 Y20 S0”.

Any idea how I might do that?

Nevermind, that’s a different issue and I’ll start a different thread. This thread is about how for some reason Pronterface is required in order to connect LightBurn.

1 Like

Thank you for starting the new thread - i’ve seen the problem you’re describing in the pic so we’ll go follow up there.

This connection issue still remains; I still need to connect and disconnect using Pronterface before starting LightBurn.

any updates? i am running latest marlin on a skr 1.3 and have the same problem. first need to connect some other way (Pronterface right now) before i can connect via lightburn.

As far as I can tell there is no progress or even acknowledgment of the issue, People seem to want to blame Marlin for not having features that commercial software like this should come with.

Does Marlin use a config file?
Are you willing to share the link to the source code?

Is it Marlin from here: Download | Marlin Firmware

I don’t have a Marlin device but I could flash a microcontroller and try talking to it - i just want to do the same thing that you’re doing so we can find the path.

Marlin uses two main config files, with some more files needing changing for some of the more advanced/unconventional features. After setting the things you want in these files you compile a binary and upload to your board. There is nothing like the config file that smoothie boards used. I am currently away from my main computer but will post my source code changes in a few days (not that it is likely to help you without having the same mainboard).

Good news is Marlin supports an astounding selection of boards. Even if you don’t have something from the list you almost certainly have something that uses the same chip as something on the list. It may be that the old 5V boards behave differently than the more modern 3.3v boards…every complaint I’ve seen has been a 32 bit board…but then building a laser with an 8 bit board would mean giving up rastering, so maybe no on has tried it.

Marlin can be found here (including source and nightlies): Download | Marlin Firmware

If you scroll down there is the source code. It is very actively developed and the Github is very active.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.