Problem Lightburn for Fiber Laser JPT 30LP


  1. Installed Lightburn and drivers.
  2. Lightburn found my laser and identified it as “JCZFiber (unknown)” mainboard bjjcz-clone.
  3. choose Fiber Type = JPT and my laser began to move from the “busy” state to the “disconnected” state.
  4. choose Fiber Type = IPG_YLP ( state laser “ready”) everything is fine and you can engrave.
  5. after choose “Fiber Type” I have to restart the board
  6. Is it ok or not to use this type of laser? can it break my laser?

If it’s a MOPA machine, you’ll likely want to select IPG_YLPM. That’s just the protocol that the board uses to communicate with the laser source. I have a 60w JPT MOPA machine, and that’s how mine is configured in both EZCad and LightBurn. Won’t hurt anything. I’d reload your EZCad driver and see how it’s configured there and replicate in LightBurn.

1 Like

No “mopa” simple 30w jpt. Settings Ezcad fiber type “jpt”. LightBurn type laser jpt not working.

so I can work with the ipg_ylp settings in LB, instead of jpt without worrying?

I would recommend e-mailing LightBurn support and letting them advise.

support response
choose Fiber Type = IPG_YLP, for no mopa JPT, !work! configured “red dot”

1 Like

A new problem

Fiber Type = IPG_YLP in LB (30Khz/15% Power/60mm)

Fiber Type = JPT in EZCad2 (30Khz/15% Power/60mm)

Different results with the same settings.

The focal length is adjusted.

Lens F290

Fiber Type = IPG_YLP Lower power, not enough power

All my settings from EZCad2 2.14.10 are not suitable for LB
IPG_YLPM does not connect (“Busy”) JPT30LP no mopa, clone board

IPG_YLP the only type of laser that connects
I decided to test it through launching “Material test” and I saw the difference, I tried it ‘Edit Material Setting’ and then ‘Reset to Default’ nothing has changed. I tried to just make a square with the same settings, nothing works.

I have already sent a request to technical support

I am thinking of purchasing my own Light Burn for my JPT 60w Fiber Laser M7.
So I just wanted to make sure Light Burn has actually updated their software for this machine with MOPA options. Shall I go for it and buy the software?

It is better to check with the “trial version” and compare the settings with EZCAD2.

1 Like

Thank you very much that is a good idea.

MOPA laser simply have a wider frequency and pulse width. There are no MOPA “Features” LightBurn fully supports changing frequency and pulse width, so supports MOPA machines just fine. Running LightBurn on my 60w JPT MOPA machine here for the last few months, and works great.

1 Like

So like EZCAD there is place to set Q pulse width. Where would I find that in Light Burn? Thank you Sincerely HammerEdge

qpulse enable q pulse
qpulse1 and the item in the layers settings appears

In your layer settings for your design, when you set the layer mode to Fill, which is like hatching in EZCad. Then, you will see your Q-Pulse Width that you can set:

Ok thank you still waiting for my machine to ship in. Your input has been so helpful. Thank you sincerely Micah

1 Like

OK. Now I am confused. With a MOPA laser there is no Q switch setting in LB. Is that correct?

a MOPA laser is not a q-switched laser, so I can’t see why you would have q-switch settings for it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.