Problem new Ruida Powerscale and switch on off Laser

Good afternoon and first of all thank you for the entry here in the forum.
First of all, a few words about me . I have a BRM laser machine from the Netherlands, I am from Germany and wanted to get rid of the f**** old software so I decided to use Lightburn and a Ruida rdc6445g.

So far everything has been changed and works fine so far.

The problem is that the laser just won’t go out from object to object.
Yes I have already read this article .

The power supply is 100% OK and not defective.

After that I have swapped 2 cables in the controller. LPWM1 and L-ON1.

Problem was solved seems so i was too stupid to connect :D.

Cuts perfectly and turns off and on.

Now I wanted to adjust the Power SCale, the laser always fires on 100%.

Even if I set it to zero.!

If I change the cables again, old problem, the laser does not switch off but I can adjust the power scale.

I don’t know what to do now and hope that I can be helped here.

Sorry for my not perfect english.

I am looking forward for your postings. :slight_smile:

Greetings Lukas

From the Ruida controller’s CN5 terminal block to the laser PSU, how have you wired that?

Ruida defaults to the L-On pin being inverted (active LOW instead of active HIGH). Some power supplies want the opposite, so you can change this in the machine settings, in the ‘Vendor Settings’ section. You’ll see ‘Laser 1 Output Signal’ and you can choose Low or High. Try the opposite of what it’s set to now.

Thank you very much for the answer.
I was actually 100% sure to have connected everything correctly.
But the problem was I mixed up the ground cable … :smiley: a bit embarrassing, but this answer helps someone else …
Greetings Lukas

So the problem was really unfortunately I mixed up ground cables.
I have played around with Low and High, come exactly to this realization thanks a lot

Hi @talis3r , I got a BRM as well, and the Leetro crashed last week. I’m sorting out how to swap it for a Ruida as well. Did yours come with a Leetro 6525A, and can you tell me how you configured it correctly?

hey
i dont know my old controller name sorry , dont see anything on the motherboard :smiley:
but yes it was a leetro and it works to swap with the ruida.
love it with lightburn it works perfect!
tell me please what do you mean excactly .
regards lukas

Well, i’ve done some research and found tutorials to swap a leetro 6515 or 6585 for a ruida, but not a 6525a. I would assume it doesn’t really matter what Leetro you’re replacing, but I’m wondering how to get the settings right so the laser and servo’s are set correct.

And yeah, I’m quite sure i’ll get a lightburn license. Will order the Ruida tomorrow and let you know if all worked out fine. Thanks.

there is no tutorial , use the ruida installation guide and it will work.
hopefully :slight_smile:
lets start the journey

Thanks for your reply. Started out with a good look on this tutorial i found:

Labeled all my wires and I was good to go.

Had some trouble fitting in the new display, but with a multitool I managed to fit it in nicely.

After all the wires were set up, I booted the controller without the servos and lasers actually connected to the controller, so I could copy the settings from the Leetro to the Ruida. Also had the problem that the image was lasered in mirror, but managed to fix that as well.

After 2 evenings, Everything was working again. Time to get to learn Lightburn.

Perfect :slight_smile:
It also took me 2 evenings until everything worked.
With a flex I also made it fit and it fits great …