Problem on square corner not straight

I did the lightburn installation on a Ezcad software. So when I import the Ezcad parameter during installation.
When I make a rectangle or a square I can not obtain square angle. Always my angle are no at 90 °.
I tried to change the differents parameters like Polygon, Laser ON, Laser OFF … no change same if I increase these parameters multiplicate x 10 I can not see any difference.
Do you have an idea what is the solution ?
NOTE If I do the same design on Ezcad it’s perfectly at 90°
Thank you by advance

Is there anyboday that has the same problem ?

hello??? Your post was made at 0300 in the morning EDT. Not many people in the U.S. will be available to give you an instant answer in the middle of the night.

The forum will see your post and somebody will get with you.

Have a similar issue w/1.4x
MacDraft, create a square edge (two separate lines ant 90 degrees), import as DWF into LB.

Preview shows corners rounded with a small radius in preview, but the corners don’t seem to have the problem after cutting (only see the effect in preview).
Hasn’t been a bother since it doesn’t affect my work, but now that someone else has noticed it…

If I look at the preview the angle at prefectly at 90 °

I really think that the problem comes from the parametres of the galvo head.
What is strange if I adjust it it has no effect.
By exemple I change Polygon parameter, Laser TC on …
no change if I increase or reduce it

Any idea ?

I’d tend to agree that your laser may be doing something not expected.

This is what I see on the LB screen (zoomed in with nodes turned on)

and this is what I see in preview (also zoomed in)
The cut comes out a perfect 90 however.

Even if the cut came out that way, not big enough to bother me.


You are right in the preview I have always rounded corner BUT I have also it on the cutting.
I tried to do a square with 4 lines and I have always the rounded corner …
So how to do ?
Any idea

Silly me, I just realized that my rounded corner is probably from the “kerf offset” being applied.

Have you looked into a square with “0” kerf offset and no other offsets?

If I understood correctly, there is the question of why the cut does not result in a verice but rather a curve.
I am not an expert nor have I ever changed or played with these parameters and I would like someone more experienced than me to confirm whether what I am going to suggest below is correct or not.
In the settings on the board there are parameters $11 and $12 which from what I understand have to do with how curves/changes of direction are managed. Taking into account that changing direction suddenly results in a kind of “knock” that can lead to unwanted deviations and loss of steps, I believe that Gcode takes measures to avoid unwanted results.
There are also axis acceleration/deceleration parameters that I believe are also taken into account to avoid the same undesired results.
With this in mind, I believe that checking and comparing the aforementioned parameters could shed some light on the subject.

Do you see the rounded corners in the Preview Window? If so, then definitely check your Cut Settings and make sure that ‘Kerf Offset’ is set to 0.

If you do not see rounded corners in the preview, try increasing your Polygon TC setting to 150, and if that makes no difference try 200.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.