Problem switching from Windows to Linux

I have a Yorahome 6550 and had Lightburn working fine on my computer when I was running Windows. I switched my control PC to Linux (Pop-OS which is based on Ubuntu) and downloaded the Lightburn Linux version and installed it. The software runs fine, except that it doesn’t recognize my laser. I contacted Yorahome to see if I needed a driver or something, and their response was they don’t support Linux - even though their website says you need a computer running Windows, Mac or Linux. Their suggestion was to contract Lightburn. Can anyone give me guidance on how I can connect Lightburn to the GRBL control on my laser?


Can you confirm if you’ve followed all the instructions for Linux installation?

Installing Lightburn - LightBurn Software Documentation

Actually, I can confirm that I did not do the permissions change.

I went back and did the permissions change and re-ran the installer, but using the Device Discovery Wizard, it still cannot find it.

Yorahome has responded additionally and suggested that I try adding the ch340 drivers per this link: How to Install CH340 Drivers -

I will try that next.

You would normally not need to do a driver install. Are you well-versed in Linux systems?

Can you confirm that the device is being detected. Can you run this in a terminal?

dmesg | grep ch34
lsmod | grep ch34
ls /dev/ttyUSB*

It’s also very possible that “Find my laser” will not auto-detect your laser. You may need to create the laser manually. If the commands above show positive results I suggest you try creating manually.

I’m somewhat well-versed in Linux. Lots of work with Raspberry Pis, but not so much with x86 machines. I’m getting ready for a Zoom Call right now so I will try this later. I can say that if I run lsusb, the laser controller does show up. I have tried creating the device manually, but when I try to issue a command like “Frame” it reports that it doesn’t appear that my laser is connected.

When you get a chance can you run the commands from the previous post?

Try these troubleshooting steps:

  1. Restart LightBurn
  2. Make sure the port field in Laser window is showing the proper /dev/ttyUSB# device for the laser
  3. Right-click on Devices button to force a reconnect

If that doesn’t work can you do the following:

Attach screenshots of:

  1. Full view of LightBurn with a job ready and Console window showing
  2. Device Settings

OK, so I ran the first set of commands and got this:
ed@pop-os:~$ sudo dmesg | grep ch34
[ 20.882329] usbcore: registered new interface driver ch341
[ 20.882344] usbserial: USB Serial support registered for ch341-uart
[ 20.882358] ch341 1-1:1.0: ch341-uart converter detected
[ 20.882841] usb 1-1: ch341-uart converter now attached to ttyUSB0
[ 23.783438] usb 1-1: usbfs: interface 0 claimed by ch341 while ‘brltty’ sets config #1
[ 23.784075] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
[ 23.784100] ch341 1-1:1.0: device disconnected

ed@pop-os:~$ sudo lsmod | grep ch34
ch341 24576 0
usbserial 57344 1 ch341

ed@pop-os:~$ ls /dev/ttyUSB0
ls: cannot access ‘/dev/ttyUSB0’: No such file or directory

When I restarted Lightburn, the port field only has the choose prompt - there are no choices to make for the ports.

Looks like the driver is loading but leaving you without a TTY. Check out this Topic and see if it applies to your situation.

1 Like

YES - fantastic. That was it. I commented out the line and it is working fine now.

One other question though - I don’t see a Fire button in the Linux version for aligning the laser to the workpiece - is it there someplace that I am missing?


Never mind - I found the setting to enable the fire button.

Thanks you so much for your help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.