xTool D1 Not recognized in Ubuntu 22.04

I am having trouble getting the xTool D1 to be recognized on Ubuntu 22.04. Things I have done so far:

  • Updated the xTool D1 Firmware to 40.30.002.01 B1 (using Windows 11).
  • Confirmed everything works as expected on Windows 11.
  • Added myself to the “dialout” group on Ubuntu.
  • Confirm lsusb shows an additional entry “Bus 001 Device 009: ID 1a86:7523 QinHeng Electronics CH340 serial converter” when I plug in laser.
  • Tried running LightBurn as root to see if it works. It does not.

I do not get a new /dev/ttyUSB0 file descriptor when plugging in the laser. I did a diff of the whole /dev directory before and after plugging it in and there are no changes. I suspect this is the main culprit here, but not really sure where to go from here.

Take a look at this post and see if it correlates to what you’re seeing:

1 Like

This was it, thank you very much! There was in fact another entry in /usr/lib/udev/rules.d/85-brltty.rules that referenced the same device ID as the laser, 1A86:7523. Commenting out that line, then restarting the system worked for me.

Some more clear instructions for future people finding this page:

  1. I noticed when plugging in the laser to my PC, running lsusb would add an entry for “Bus 001 Device 006: ID 1a86:7523 QinHeng Electronics CH340 serial converter”. Jot down the device ID: “1a86:7523”.
  2. Run the following grep to see if there are any udev rules for the same device id. grep -riIn "1a86:7523" /usr/lib/udev/rules.d/*
  3. If any results appear in the above grep, open that file as root and comment out the offending line.
  4. Reboot the system, and try the laser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.