Problem with engraving file or program

I have no idea what this software is… :crying_cat_face:

If you put it on your lan, you can see it in your device manager. This eliminates a lot of usb issues. I don’t run Windows, so I don’t keep up with it and all the driver mess using usb.

Unfortunately that doesn’t help you if you can’t implement it.

You have a full list of files on the Ruida, have you tried to removing them?


TrustViewer or TeamViewer program has been specifically designed for operational support for users through the Internet: client needs just to download the small application with a short address, run it, and tell the session ID to the support service. Herewith, at the client’s side the program starts up without mandatory installation on the computer, even with minimal user rights of level “Guest”, does not require setting the firewall or proxy, and is automatically updated if the support is using a newer version. Attention! For maximum efficiency and security, connection to a remote computer is implemented by method of direct connection “point to point” without involving the Internet servers (hybrid p2p networks), this means that at least at one of the parties (usually it’s the support service) the computer must be configured to receive incoming Internet connections or be connected to specialized proxy server, and in most cases the program can make all the necessary settings automatically. In case of impossibility of direct connection - the connection will be established through one of the Internet servers, but in this case there may be limitations of the functional of a program, depending on server load.

I don’t have a local network, the laser is connected directly to the computer. Laser connected to usb hub Com4 port

are you talking about a list of files on Ruida, are you talking about layouts I downloaded on Ruida or other files? I certainly deleted layouts from Ruida)

Most people have a router they use for various computers… this is usually on a local area network, different domain from the world wide network.

I wouldn’t have anything that required a network connection to operate my machines…

I guess it’s not an option for you.

Good luck


you did not understand me, the computer is connected to a router for accessing the Internet, but the laser is connected to the computer. the laser is not connected to the router.

I believe it went both ways :crazy_face:

The connection from the router to your computer is your lan.

The Ethernet from the controller will plug into the lan for a more consistent connection…

I can’t help you much with the usb connection. I quit using that within a week of the machines arrival…

Good luck


perhaps we did not understand each other. who can help me with usb. can you direct me? I will be very grateful to you.

If the laser is working with RDWorks it’s likely not an issue with the USB.

First, can you confirm that the laser head on your machine homes to the bottom-right? That’s how you have LightBurn configured.

Second, let’s remove USB from the equation. Try this:

  1. Create a simple rectangle in LightBurn
  2. Set layer to Line mode. with moderate settings for the layer: 50 mm/s, 15% power
  3. Push “Save RD File” in Laser window and save to a file
  4. Transfer RD file to USB drive
  5. Plug USB drive into controller and run the file from the panel

Does this work or are the symptoms the same?

I tried loading the created .rd file into the laser
I copied the file to a flash drive, then inserted it into the USB connector of the laser. writes invalid file and unknown file. The laser machine cannot open the file.

There are two USB connectors. One is for USB cable for connection to computer. The other is for UDISK (USB drive). Did you insert into UDISK port?

Also, can you upload the .RD file here for review? You may need to add a .txt extension to the file to do so.

yes, I inserted into the second usb udisk time. about expansion to change rd to txt. I will check.

Try a different USB drive.

How has the USB drive been formatted?

FAT32, the laser sees the .rd file, copies it to its memory, but it does not read it. changed the .rd extension to txt. laser doesn’t see the .txt file on udisc at all

It has to read it to copy it to it’s memory… What exactly are you trying to say?

Can you select the file from the console?


I selected udisc, the laser could not read to file, then I clicked copy to memory. That’s all I did, the file extension was .rd. the laser sees a file with the extension .rd but cannot read it

did you set the origin and then run the box to make sure you are not out of bounds?
Also if its a new install of LB might need to calibrate the axis.

The file name have the simplest possible format:

  • No more than eight characters
  • A-Z, 0-9, hyphen, underscore
  • No spaces

All the fancy file names we’re used to just don’t work in the laser controller context. :person_shrugging: