Problem with home position switches

I have been using Lightburn for a about 2 years without any major issues, but suddenly I have a problem with my home position switches. I have micro switches connected in parallel and connected between ground and pin D9 on the arduino nano on my grbl controler, I have checked and both switches are working correctly but when I tell the machine to go to home, the X axis moves correctly, hits the switch then backs off a little, but the Y axis just hits the switch and tries to drive past it.
I have replaced the nano but this made no difference.
Any suggestions? Have I accidentaly changes a setting somewhere?
I am using firmware 1.1f

Edit to add, I have found that connecting the Y home switch to pin D10 now homes correctly (didn’t need a seperate pin before!) but now the machine wants to home to the wrong position!.. getting there slowly!

Hello. Home switches for Y and X axis must be connected on different pins, on D9 and D10, not in parallel on same input.

Arduino nano

Thanks for that, I can now make the machine home correctly when I select the “Home” button or send $H, but when the machine connects I get
[MSG’$H’ |’$X’ to Unlock]
[MSG:Caution: Unlocked]

The machine does not home automaticaly on start up, but everything else seems to be working fine.
Not a major problem just annoying! (I have checked the limit switches are working fine, now using grbl 1.1h)

Update, I have re flashed the firmware, everything now working correctly!

I’m getting the error 9 also, can you help with what you mean by “re flashed” the firmware? I ran xloader(from jtech site), but can’t find the grbl.hex its referring to?? any help is greatly appreciated. I just didn’t want the “error 9” to cause an issue, thanks

I connected the limit switches to pins 9 & 10 of the arduino nano, for the firmware, after a lot of trial and error I downloaded a copy of T2 Laser (works ok but not as good as Lightburn) I selected “control laser” then “machine” then “custom firmware” then uploaded 1.1f XY Home Sw.
Works perfectly now.

Edit to add, I also disabled the Hard Limits setting in Edit - Machine settings ($21)

hello, i have found the good solution, i have write it in french
the link to the solve

dont take care of the pinmap

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.