Problem with jogging

Not exactly sure how to describe what is going on. First of all the machine is connected to my PC with com 3 port. When I try to jog I get errors either error 8 or error 18, says, " Grbl $ command cannot be used unless Grbl is idle."
Ok but this is on first and every reboot of machine and lightburn. I can reset commands and reboot both machine and PC, still the same. I have tried more than one Pc, no change.
when i try to use G code commands,…g0x20y20, I get an error 9, “gcode locked out during alarm or jog state”.
I reboot machine and pc. still no change. I have changed the USB cable and tried a different port on PC., I have even used a differant PC.
no differance.

I have been chatting with Timothy Rothman, He thinks it is a glich in Lightburn.
I am looking for help and suggestions on what the problem is. any help is appreciated. TIA.

I assume then that this is a 32 bit Nano Black-N-Blue grbl board? Kind of an odd thing to say when all the messages are generated by the controller and not by LightBurn.

Can you power cycle the laser and capture all the output from Console from boot until idle?

Also, provide the following:

  1. Does your machine have homing switches and equipped to home?
  2. Has this machine ever worked?
  3. Enter these commands into Console and return output:
  1. Screenshot of Edit->Device Settings
  2. Full screenshot of LightBurn

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.