Problem with Laser calibration

Hello there,

i have an Atomstack A5 M30 Laser which was running really well with the LightBurn software.
I don’t think my problem is a software problem but maybe someone advanced can help me.

All over sudden my laser lost it’s accuracy, i ran the attached project and got the following results. as you can see the edges get wobbly and somehow the ends of the hexagon don’t meet anymore.

I tried adjusting the pulleys and the belt but with no luck.

If you guys have any idea how i can fix this i would be verfy grateful.

EDIT: after further investigations i realised, that the stepper motor for the y axis seems to be too slow when starting a downwards motion. I have had some issues with the motor crashing into the end at the bottom. Is it possible that i simply tore down the gearn of that motor?

atomstack_a5_issue.lbrn2 (11.7 KB)

Check the pinions that are mounted to the shafts of the stepper motors, particularly the Y-stepper. I’m guessing the pinion has gotten loose and is rotating around the shaft.

Examine it. If there is any play at all then resecure the grub screws that hold the pinion in place. Make sure one of them is secured against the flat portion of the shaft. There should be essentially no play between the shaft and pinion.

1 Like

Hi,

and thanks for the quick answer.

I already checked the pinion and it does not seem to have any play.

How thoroughly did you check the pinions? Did you remove the belts for a thorough review? If not, I suggest you do so as I think this is the most likely problem area.

If you’re reasonably certain the issue is not in the pinion then do a full mechanical review of the machine. Start by slowly moving the laser head around the entire frame. Does it move freely to every corner? You’re looking for any sort of binding situation or note if there are any areas that are not as smooth as others. If you find something, try to isolate what is causing the anomaly.

Less likely the issue but check that the laser head assembly is properly secured on the gantry. Check for proper gap of wheels to rails and adjust appropriately.

1 Like

Thank you so much PY,

i checked again and there was one pinion that i did not check correctly.

Now everything works great again.