Problem with pen plotter fill layers drawing traverse lines

I have an OpenBuilds Acro 1515, Blackbox x4 Controller, using GRBL-M3.
I have converted it to a pen plotter using a stepper motor as a z-axis to lift the pen off and on the page.

Doing LINE based designs this has been working great by replacing the M3 and M5 commands in the gcode to custom ones to lift the pen up and down using Z axis commands.

I am having issues with FILL though. When doing solid shapes that have large gaps in between, it draws fine (draws one shape, lifts the pen off the page, then draws the other shape). But if the shapes are very close together and joined, lots of traverse lines appear in the gaps - however there are no M3 or M5 commands in the code - so the pen plotter doesnt know to lift the pen up and down for these small traverses.
The pen lifts off the page for the beginning and end of the drawing - but not for the small traverse lines in the middle.

Example below showing the preview in Lightburn. I was able to eliminate the small traverse lines in Lightburn by adjusting the layer setting ‘Speed (mm/sec)’ from 100 to 1 - however then the machine draws incredibly slowly.

Another example out-putted from the OpenBuilds CAM Gcode Generator - which is the same shape - but no traverse lines in the small gaps. This draws fine on my rig - however I use Lightburn as my real designs are very complex and OpenBuilds CAM cannot handle the complexity.

Any help or tips appreciated!

The problem is that LightBurn doesn’t do retracts - it uses G1 moves for the whole fill, just with the S parameter set to 0 when doing travels, because it gives more consistent motion and produces a better output.

You could try using the Offset Fill option for now. We have a ‘Pen Mode’ option in the works that should be ready soon, too.

Thanks switching to Offset Fill works a treat!

Using it sparingly only on layers where traditional FILL produces the traverse lines, as its very processor intensive for complex shapes - but it gets the job done!

Very keen to follow any updates for ‘Pen Mode’.

Cheers.