Problem with project stopping part way through

Hey guys, I am fairly new to laser and have encountered a issue I can’t seem to resolve. I have a project that keeps stopping part way through with error “error:bad number format on or near line xxxx:Job halted” I have designed multiple projects and this is only one doing this so far. I have a Gemitsu LC60a 5w, running Lightburn 1.4. Any of you guys have an idea what might be happening? The crazy part is when first designed on free trial period this project worked, when paid for it is when issue started.

There is no functional difference between the Trial and Licensed versions.

Go to Edit, Device Settings window and look for the Enable Gcode Clustering button and turn it off. Some controllers do not accept clustering (a very condensed form of Gcode).

Thanks for the response MikeyH, will check that on my shop laptop tomorrow. The one I am on now has it disabled already. I use this one while in the house to design my projects than transfer the files to shop computer running the laser

Do you load them into Lightburn to feed them to the controller?

yes i have my second Lightburn on my laptop in shop, but no internet out there, I just copy to project file onto a jump drive, then copy to the project folder in the shop’s lightburn, and run the laser through lightburn. Seems to work ok with other projects I do so far. This one may be a bigger file if that makes a difference. Seems to mostly stop during a fill burn on second part of the cross-hatch burn.

ok, i still can’t figure it out. I used my house laptop this time which is a Dell G5 SE, a gaming laptop with much more memory and processing ability and still same issue. I found that if i remove the offset fill on one of the cut/layers it didn’t stop during that portion any more, also had to remove the cross hatch on another layer to keep it from stopping during that layer/cut. Managed to make several of my project coins then, but had to turn the output off on the final cut layer to keep it from stopping during that process. Very aggravating, it worked before when I first made the project. I have deleted it and made it over again but no difference. Does anyone know if there is tech support from Lightburn i can contact?

There should be a few of us around today.

The Line number where the error is produced and the GCode that was sent should be enough to track it down.

Please retest the file that is on the shop computer.

If you’d rather enjoy peace and quiet feel free to unplug the laser module from the controller (for this part of the test).

When the Job Halted error message comes up, select and copy the text from the Console window where the error message appeared and paste it into a reply here.

Then, in LightBurn click File, then save GCode and save the file somewhere handy. Change the filename to end .txt and attach the file here or send it to me as a direct message here.

It should be obvious when I look at the line of code. If the error doesn’t occur or if it’s not obvious then it may be some noise or static electricity causing data loss.

Thanks John, will probably be next weekend before I can get to it but I will definately get the info your asking for. I had a suggestion from another site that recommended I replace the usb cord to the laser with a higher quality one then what came with the Genmitsu. That may be cause of the noise you mentioned, so I will try that also.

1 Like

here is screenshot of error code, it is not always the same line number. Also the gcode file.

old guy 10 coin.txt (1.9 MB)

Please change your Device Profile from GRBL-LPC to GRBL and re-test.

Something unintentional may have shifted the profile when you ended the Free Trial. It shouldn’t have done this. I’ll ask what ‘might’ have happened.

Thank you John, I will try this. Do I simply just type in GRBL in the device profile or do I have to do additional things? Like manually install my laser and input size, etc. I will let you know the results, this is probably the issue. Thanks again!

In the Laser window, click the Devices button on the Left toward the bottom.

With the current profile, click Edit, select GRBL and follow the process.

Once you have an active GRBL Profile, click Edit, click Machine Settings and click the Read button at the bottom, then click OK.

Please let us know if this resolves the ‘bad number’ error.

looks like it only changed the message, but same results. I attached copy of message again and the gcode.

old guy 10 coin.txt (2.4 MB)

The saved GCode file looks fine. It’s possible the sent data is dropping a letter or a number out of the line. If the Genmitsu forum recommended a better usb cable that could be related to data loss as well.

With a GRBL profile selected, we have access to a Device Setting to control the baud rate (communication data rate). Click Edit, Device Settings and if it’s set 230400, test with 115200 or even as low as 9600. It shouldn’t need to be that slow but it’s good to test. Click OK at the bottom of the window to save the change.

If that doesn’t address this behavior, or if the engraver won’t down-regulate and communicate more slowly, changing the cable would be a great next-reasonable step.

John I have already replaced the usb cable with what supposed to be gold plated and has 2 ferritt chokes on it. I know my baud rate is at 115200, so I will try a lower setting and let you know. I have been corresponding with the Sainsmart support on this issue also since a new machine so waiting on their reply to the last test results. Same as I sent to you. They are leaning towards sending me a new control board since only few weeks old. I will let you know results. Once again I appreciate you taking time to help me on this issue.

1 Like

update, lowered baud rate to 9600 but same result. Sainsmart support is sending me a new control board for the laser under warranty, think we covered all other possible causes. will let you guys know if it works.

1 Like

Please let us know if this resolves the behavior. If it’s not a terrible inconvenience, when you’re swapping the control boards please take good close-up pics. If there’s a bad batch, a change or a ‘deleted component’ that’s being managed quietly it would be very helpful for us to know this and to document the ‘first instance’.

Please do, and thank you for sticking with this. It’s incredibly powerful when the community works together to resolve technical challenges.

Thank you, none of this would be possible without your efforts as well.

ok, i received the new control board from Sainsmart during the week and installed it today. Sorry I forgot to take pictures but did not see any differences in the two. I ran the problem projects and they worked as expected as far as the machine is concerned. Just need to learn how to keep things lined up when trying to burn 2 sided project.

If you have Limit Switches on your Gemitsu LC60a and a couple of sharp corners or pin-holes to work from (or a really precise jig for workpiece placement), you can use Print and Cut to align your engraving to the back of your project.

Thanks John, I will look into the Print and Cut feature.