Problem with recognizing camera

Hi! I have a problem with my windows recognizing my webcam id…i have a logitech c270 and my pc can’t install it as a logitech c270 webcam but as a “usb cam”…this is a problem because lightburn then recognizes only its default resolution (640x480) and not custom resolution. i went to other pc’s and this isn’t happening to them. i have checked all windows security parametres and everything is enabled!

You may need to install the specific driver for the camera:
Downloads - HD Webcam C270 – Logitech Support + Download

Or possibly the Windows Media Feature:
Download Windows 10 Media Feature Pack (

1 Like

Have you connected the C270 directly to your computer via USB being sure there are no hubs involved? Then check that camera in the Camera App and device manager to see if its recognised as C270. You might also consider seeing if Logitech provide a driver file for it.

Yes i have done all these things…Logitech doesn’t have any drivers for win 10 for this camera…it’s supposed to be plug and play… Oz had a link at the past for problems like this…

Not following why you’re saying there are no drivers for W10. Did you check the page I linked?

Is this something different? Or perhaps a different version of the camera?

If not, are you able to do a driver update from device manager?

yes I have done all these things but still lightburn recognize my camera as a usb video device… :roll_eyes:

Perhaps try picking the driver manually.

Device Manager->pick camera->Driver->Update Driver->Browse my computer for drivers->Let me pick from a list of available drivers on my computer

What devices does it show you? Is the installed Logitech driver shown there?

yes eveything is correct…what else can be blocking windows to receive the id of my cameras?every possible suggestion is checked!

I don’t understand. What devices showed when you did this? Can you take a screenshot?

Have you tried contacting Logitech for support? Have you tried plugging into another USB port?

Yes I tried almost every port of my pc…this is what I am seeing on lightburn…

That screenshot shows the USB camera by name. Wasn’t the problem that you were getting a generic USB camera device?

I meant can you take a screenshot of the device manager screen listed here…

yes at the beginning i was getting a generic name…then i downloaded a driver finder program and found a driver for the cam…but as you can see the problem with getiing image consists on lightburn…i will post a pic of my driver list when i get back home from work…thank you very much for helping me resolve my problem

Those updates on progress are required to make sure we’re on the same page.

If now you’ve resolved the driver issue then it’s likely a permission issue.

Can you confirm that you get an image using Windows native camera app?

If so then make sure you’ve granted LightBurn permission to the camera. You may also need to provide permission to the microphone. You may need to reboot for things to work.

1 Like

I can’t believe that I found the solution to this problem! my microphone permission was off and was causing the problem… now full resolution is set!

1 Like

Isn’t that what I said in my previous post?

1 Like

yes that’s why I am trully gratefull for your suggestion!

Oh. I misunderstood. You marked your own post as a solution so thought you were saying you solved it independently.

Glad you got it working.

no no! by mistake from my joy that at last fixing this thing! have a good night and I hope your suggestion will help others!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.