Problem with Sculpfun s10 10W

Please help. my Sculpfun s10 10W stopped working. Apparently it does not communicate with the PC (I already tried several cables and even another pc), neither port is activated in LaserGRBL nor in LightBurn (both worked before without problems). The red led inside the motherboard used to stay blue. Also sometimes when I plug in the USB the laser lights up by itself. It seems to be the motherboard. I also tried reinstalling the driver. Please, any suggestions? I really need your help. Thank you.



To me, it looks like the power supply is broken. Only the VIN LED is on, the 5V and 3.3V LEDs should be on as well.
Can you measure if the power supply is still working?

Yes, the laser turns on! but don´t comunícate to the PC, new USB cable and computer is already tested, but problem persist.

So, the fan turns on?

If you suspect a broken mainboard, send an email to support@sculpfun3d.com and they usually send a new one.

I have same problem! Did Sculpfun solve yours?

Describe your problem. If you connect the laser, do you find a device in the Windows device manager? Which port does it get assigned, if any?