Probleme avec le kit update 22w sur une sculpfun s30

je viens d’installer le kit update de 22w sur ma sculpfun s30 et impossible de faire un home l’axe y est ok mais le laser part sur la droite et ne s’arrête pas. j’ai réinstallé le logiciel avec la dernière version et j’ai essayé avec la 1.5.00 rien n’y fait j’ai toujours l’erreur 9.
Je ne suis pas un pro, je viens de commencer, avec la 5w je n’ai jamais eu de problème.

Hi Martin!

Homing preceeds Lightburn.
In other words, is your motherboard firmware that is calling for the machine homing cycle

Your description - and adding that you upgraded to the 22W - imply some hardware issues.

Try this for me:

  • unplug usb cable
  • make sure your X stepper motor cable is fully pressed in the motor
  • confirm the X belts and Y belts did not become loose

Once done, move the laser head to the center. Power on the machine.
Would it be possible to maybe record the homing cycle on your phone and upload to YouTube. If so, please share the link with us

Good evening,
I have just installed the 22w update kit on my sculpfun s30 and it is impossible to home the y axis is ok but the laser goes to the right and does not stop. I reinstalled the software with the latest version and I tried with 1.5.00, nothing worked, I still got error 9.
I’m not a pro, I’ve just started, with 5w I’ve never had a problem.

Did you make an adjustment for the larger laser module? Your work area will be smaller, and the maximum travel will be smaller also. I had to make corrections when I added a manual Zaxis adjuster.

Yaxis will need reducing for sure. Parameter $131
Xaxis maybe. Parameter $130
The Yaxis Home switch will have to be moved back as well. The S30 has two extra holes for the switch, so one of those might work for you.

You might find this site useful. It is all things Sculpfun. Scroll down to the Assembly / setup instructions section for the S30 machine.

Merci Mike, j’ai réduis au max mais rien y fait la machine fonctionne à l’envers,
et se met en alarm 8.


Merci Gil, mais est ce que je l’a met en auto home dans Ligthburn, car ça fait au moins 8 fois que je réinstalle le logiciel.
J’ai lu qu’une personne avait refais les réglages directement avec le service technique de Lightburn, mais ne parlant pas anglais je n’ose pas les contacter.

My mistake! I forgot to include the link. Here are two you will find useful.

Thanks Gil, but did I put it in auto home in Ligthburn, because I’ve been reinstalling the software at least 8 times.
I read that someone had redone the settings directly with the Lightburn technical service, but as I don’t speak English I don’t dare contact them.

Lightburn has members speaking many languages. A lot of us use Google Translate, like I did here, and seem to be very successful. Do not let the “ne parlant pas anglais” language barrier keep you from asking questions.

Thanks Mike, I reduced it to the maximum but nothing worked, the machine works backwards,

Two things can cause it to work backwards. The GRBL parameters are messed up, very unlikely on a new machine, and it is hooked up wrong… Common is the plugs inserted backwards on the stepper motors.

The Sculpfun S30 is about as close to Plug and Play as you can get. On mime, I only had to change one GRBL parameter for it to be fully functional.

If the machine was working properly at one time, then we will assist with that too.

Merci Mike, je vais étudier cela pendant la semaine.
j’ai encore une question, je viens de démonter à nouveau le de commande (3eme fois), et sur ma carte mère c’est marqué S30 Ultra version 1.1, suis-je obligé de la flasher?

1 Like

You can always write to support@lightburnsoftware in french Martin.

The team will do their best to reply in French too - even if using translator

Make sure you request that.

I been working with someone else with S30 that homing was going X > right instead of left

If so → Edit > Machine settings > invert X axis mask $3. Click True and Write

Vous pouvez toujours écrire à support@lightburnsoftware en français Martin.

L’équipe fera de son mieux pour répondre également en français, même si elle utilise un traducteur.

Assurez-vous de le demander.

J’ai travaillé avec quelqu’un d’autre avec S30 et la prise en référence allait vers X > droite au lieu de gauche.

Si oui → Édition > Paramètres machine > inverser le masque de l’axe X $3. Cliquez sur Vrai et écrivez

Sorry double posted what you said :smiley:

I have no idea what this means, but I accept the apology anyhow!

I said what you had already said about Lightburn Team is being able to speak other languages

No apology needed! We are all trying to help.

1 Like

Thanks Mike, I’ll look into this during the week.
I still have one question, I just disassembled the control again (3rd time), and on my motherboard it says S30 Ultra version 1.1, do I have to flash it?

They probably use the same motherboard for all the S30 machines. Flashing is a drastic move and should only be used as a last resort.

I recommend that you answer questions when asked, and see if that solves your problems first.

I am going to be offline for a while, but @gilaraujo is very experienced and will be able to help you.

Gil, Mike , merci car grâce à vous deux je ne me suis pas découragé et maintenant ça marche.J’ai fait “Edit > Machine settings > invert X axis mask $3. Click True and Write” et la machine c’est mise à fonctionner correctement. Merci encore à tous les deux.

Très amicalement

PS: je récapitule les symptômes de la machine pour que ceux qui auront les mêmes problèmes ne cherchent pas trop longtemps.
1- j’ai installé le kit upgrade “ultra de 22w” sur ma Sculpfun S30 5W.
2- ma carte est une sculpfun s30 ultra ver 1.1 ( qui ne correspond pas à la photo sur la fiche de montage. Toutes les fiches sont à la bonne couleur il n’y a plus besoin de mettre la fiche bleue dans un récepteur blanc.
3 quand j’ai mis en route avec Lightburn, j’ai défini la taille de la surface de travail qui est "375 mm de large sur 380 mm de long je n’ai pas de kit d’extension, j’ai défini le le “home” en bas à gauche et j’ai activé le “auto-home”, puis écrire,ok.
4 - à ce moment la machine c’est mis a travailler l’axe X à l’envers, ce qui me mettait des erreur-9 dans la console.
Grace à la persévérance de GIL et Mike la solution est "*“Edit > Machine settings > invert X axis mask $3. Click True and Write” en français "modifier>Paramètres de la Machine>déroulé le output setup>X direction invert ($3)> mettre le curseur en vert sur Vrai.
NB faites confiance à la communauté il sont géniaux, et vous répondent même le Week-end.

I am a bit puzzled on this though, because if one is to reset S30 to defaults it all goes wrong.
@misken being you the wizard on all things Sculpfun, why would the firmware default to - incorrect values?

Small “oopsy” from Firmware team?

I would never rule that out - but in this case the most likely cause is that the Ultra upgrade kit contains a new mainboard. This mainboard can be adapted to all Sculpfun machines. And not all the machines use the same x-axis direction (for example, once the x-axis was changed from rollers to linear rail, the x-axis direction had been inverted). So, the firmware will be set incorrectly for one set of machines, regardless of what they do :slight_smile:
The Ultra upgrade kit mostly targets users of older machines, especially the S9 series, which has the former x-axis direction. So the firmware is set to make it easier for S9 users (majority) and will be inverted for S30 users.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.