Problems during firmware upgrade of OLM2 pro S2

Hi all,

I have problems upgrading my OLM2 pro S2 to latest version of the firmware.
This is what I get when I run $i command:

[ORIGIN: China]
[MODEL: Ortur Laser Master 2 Pro S2]
[OLF: 185]
[DATE:22:44:33 - Oct 25 2021]
Target buffer size found

and because of OLF > 180 I downloaded the latest firmware from here of the 1.8 series: Ortur Laser Master 2 Pro S2 - OLF 1.8 Series

I then set the laser into “firmware mode” and tried to copy the .bin inside the zip into the mounted folder. Whenever I click CTRL+V (paste) the laser shut down and stop the copy of the firmware bin.

I then tried another PC (arch linux one) or different usb cable… Nothing changed! All the time the laser just shut down itself. I even tried other firmware of the same 1.8 series (both 1.87 and 1.90) but no luck.

I’m start thinking I pick the wrong firmware but I really don’t get which one else it could be. This is what that says on how to identify the correct firmware series:

Can you please help me?

Thank you in advance,

I’d suggest extracting the firmware from the zip file first. Then copy the .bin file to the target location.

I believe the firmware you’ve linked is the correct one.

thanks for the answer!

I forgot to write it but I actually unzip it all the times and then try to copy the bin inside the folder. :smiling_face_with_tear:
Any other idea?

Thanks again,

Can you take a screenshot of you attempting this? Maybe something subtle going on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.