Problems installing LB on silicon MacBook Pro (M2 chip)

Just paid for a license and now find something in the LB and/or Mac blocks installation because it requires Rosetta to run an intel based app. The first time I tried to open LB I got the dialogue to install rosetta but it could not. Thereafter I get a dialogue saying I should check my internet connection (it is absolutely working 100% OK). Is this related to the unidentified developer question?

What prevented the installation? Can you attach a screenshot?

Unlikely. Notarization is independent of Rosetta layer.

this is the screen shot I get now when trying to open LB

Do you have anything that shows the error for Rosetta installation?

If not, you may want to install Rosetta manually.

Run this command in a Terminal window:

/usr/sbin/softwareupdate --install-rosetta --agree-to-license

You may be prompted to enter an admin password. Note any error messages and copy here. If install completes without issue then try rerunning LightBurn.

thank you for your assistance. A simple (2nd ) restart seems to have solved the problem. I guess I panicked - sorry

Glad it’s sorted. I recall a different user having a similar Rosetta issue. I suspect it’s an initialization issue with first install where not all components get started correctly without a restart.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.