Problems using Laseraxe Control Board

I’m very new to this however, simply put, when I import any file ( and I’ve tried every type available because I’m not sure if that makes a difference ) the software will either show the message in the attached image or the laser itself will move to the first point to begin cutting/engraving and will do so for about 1 second and then seize to move any more. The laser is still on at this time resulting in a small burn mark before I stop the process. I have messed around with the settings for too long and have now eventually gave up trying to solve this problem. As I have tried to alter every setting one way or another and manged to get nowhere, I am under the impression that the problem may be hardware related, or firmware I have no idea. I am running what I believe is the latest version of LightBurn as I have recently started the trial, and I’m using a Laseraxe Desktop Engraving with a Laseraxe CNC 3 Axis 2 Phase 4 Wire Stepper Motor Controller which is GRBL based. (No idea if i’m saying that right, I am a complete novice). I am not sure what version of GRBL it uses although when it shows up in my devices it is under the GRBL-M3 (1.1 e or earlier). What am I doing wrong, or what do I need to do to fix this. If I need a new board, which one should I buy? Thanks in advance.

A couple things stand out:

  • The board you’re using has GRBL 0.8 loaded. That’s very old, though it might still work.

  • You appear to have homing on startup enabled for the controller (which is the default), but the machine is responding with “Error: setting disabled”, meaning that the controller likely doesn’t have limit switches installed.

  • The board is responding with “(0/0)ok” to everything, but LightBurn is looking for “ok” all by itself - this is likely the format of the older firmware. I haven’t tested LightBurn with anything older than GRBL 0.9, so this might be the cause of the issue. If you can update the controller to a more recent version of GRBL you’ll probably have a smoother experience.

Ok great, thanks for the quick reply. Can you tell me how I would go about doing this, or would that be outside the scope of this forum? I am enjoying using the software as I can already tell it’s way better than what I was using before. If not able to explain how to update the version of GRBL, would you be able to recommend any board that might work? Thanks again.

I don’t have any experience with this hardware, so I’m not sure how you’d go about upgrading it to a newer firmware. Others here might have experience with it, or you could try contacting the company who sells it - they have their own user forum here:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.