Problems using rotary tool

I’m using an Ortur Lasermaster 2 Pro with the YRR rotary tool. I set it up using this video and it works seemingly fine.

I wrote a file to burn on a wooden bottle. rotary_forum.lbrn2 (102.7 KB)
The first layer burns 6000 mm/min @ 85%.
The secon layer burns 6000mm/min @ 35%.

The problem is, that there seems to be an offset between the layers.

I figured it had something to do with the speed of the Y-Axis (the rotary tool), so i set the line after fill to just 50 mm/min.
That didn’t help so I thought the movement between burning was too fast and the problem for the offset.
So I took a look at the GRBL Settings and change the following:

$110 6000 X-axis maximum rate,mm/min
$111 500 Y-axis maximum rate,mm/min

$120 500 X-axis acceleration,mm/sec^2
$121 300 Y-axis acceleration,mm/sec^2

But it is still the same offset. Every time it looks the same.
Is it maybe a different mistake? Some kinf of software mistake im overlooking?

Greetings Tom

Have you checked to see if the diameter and circumference setting are correct?

Yes I have and they are correct. But I can’t see how that is relevant. Wouldn’t a wrong number just result for example in a wider burn?
It even says in the Rotary Setup menu “For a roller rotary the values below are not required. This is just a useful calculator”

However I do suspect some wrong settings.

I have already seen this phenomenon with my DIY rotary tool. In any case, I find the speed when rewinding is too fast. I don’t think that’s because of the software. With fast reverse, something like a “slip-stick effect” can occur because there is no fixed connection between the roller and the object. The object can slide easily on the roller when accelerating. If you only edit objects in “Fill-Mode”, this does not apply because the roller moves evenly in one direction. However, if you use a combination of “Fill + Line”, e.g. for fonts that are filled and then have a border, the result can be fatal. The result is an offset. That’s why I only use the “Fill”-mode.

there shouldn’t be any slipping. due to my settings it is soooo slowly moving. but i will try burning only with the fill option to see how it looks

A wheel type rotary is configured so the surface of the wheel moves the object at a specified ‘surface speed’ or equal to that of the Y axes. The wheel just drives the object, so there is no need to know the diameter of the object.

A chuck type has to ‘compute’ the ‘surface speed’ of the object and needs the diameter data to do that.

@WF55 is correct, as most of my problems are from the object ‘slipping’ or moving on the rotary. Wheel types are the worst… I have a rather expensive rotary (PiBurn) and have my Ruida slowed way way down for doing some types of work.

If you are using an kind of ‘line’ modes, these are vectors and will probably exacerbate any slipping issues. The most dependable is to use an image type or bitmap conversion and let it scan with the fast axes and rotate the object with the other axes.

Good shot at a ‘fix’ with the modification of the speed/acceleration values… if anything it’s the acceleration values. My values for my rotary are in single digits for vector graphics on mugs… Maybe you didn’t go far enough…

If you think it’s speed related, set both to the same speed and see if it’s an issue. You’ve apparently have a couple of cups to try it out on…

Good luck… Welcome to the wonderful world of lasers/rotaries… :crazy_face:


I did it, but it was frustating ^^
First thing I noticed: Even just doing the two different layers (just fill) resulted in an offset. Even when I set the y-axis acceleration to 1 mm/s². For some reason the line after fill wasn’t even the problem, but the going back to the origin after one layer. (I used 3 layers in the project, my file was simplified)

What I did to make it work was a piece of masking tape on the bottle, where i drew a tiny dot. Then I did every layer individually and before starting I navigated back to the dot. Because after the first layer, the laser wouldn’t be on the dot anymore. (approximately 1mm off in both directions)

But what I was thinking about is a 3D print with a wooden spindle, that I fixate under the rotary tool. So I can use two big rubber bands, to “hold down” my object so there shouldn’t be any more slipping.
Any thoughts on that? Anyone done that?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.