Problems with Fill

Is anyone else having problems with “Fill”? For some reason when I select Fill in Lightburn, it still shows as Line.

When you ‘preview’ the file does it not show as filled ?

Yes, it does. Did I change a setting somewhere?

To see it filled on the work screen you need to select one of the 2 filled options from the drop down ‘Window’ menu

Ahhhh, yes! Thank you I accidentally turned that off. Thank you!

My pleasure :+1:

You actually should leave LightBurn in wireframe mode. :slight_smile: This is the default view, as objects can become hidden behind another object or obscured by the layout drawing order, making it difficult to view or produce as expected. Viewing in filled mode can also be confusing when wanting to select an object or edit shapes / elements of your design. Wireframe is the default view for design and edit work. The filled rendering view is intended for spot checking your work and should be used with this understanding. To see what will be sent to the laser, ‘Preview’ is your best friend. :wink:

I’m not sure if I should have put this in a new issue, however, this is a fill problem. image

Both images are the same, the left is showing the nodes. I can not get this object to fill. The marching lines are active on every segment after using auto close & selected segments with tolerance.

I just don’t/can’t find a way to make this fill and need some help. I have noticed several larger nodes apear. Highlighted on the right imate. Those nodes will seperate without ‘tugging’ the opposite node. From experiment ‘all’ other nodes are connected and one node will pull both lines.
Are the larger nodes an indication of anything? How do I locate where the problem(s) are at.
Also, should this be in its own topic?

This can happen, try this, select the shape, then Alt-B to Break Apart, followed by Alt-J to Join back together again.

Edit, wait…you can not have what you show close, you have a line crossing. It may look like 2 shapes, but it is one shape, with an additional line. You need to choose one path and ensure it is closed to have it fill.

imageimage or image or image

I can see you made this happen, but I couldn’t repeat with the same result. I removed the ‘bottom line’ so I wouldn’t have to deal with it. I tried the Alt-B in normal view and in Node mode. The break was successful but the Alt-J didn’t connect.

What view does the break and auto join work?
Is there any significance with the enlarged nodes. The one in the upper right was end/start nodes (which wouldn’t join)?

I’ve been struggling with this for 8 to 9 hrs now… need to be done for now. I’ll attack it in the am. Thx.

I did this with a screen capture software and only did to highlight / show example. :wink:

Post the LightBurn file and I will take a look.

You probably have 2 not quite properly closed shapes and therefore can not fill them.

@Rick, I don’t know how to post the LB file, need to know how.

@bernd, I agree, there are 3. Just can’t find them. I tried to view with preview and got this message.image
Selected continue but nothing showed up in the window. For now I’m lost.

Going back and try to figure out the Alt-B (works great). Alt-J I can’t seem to get anything to re-join back to where it was before I used the Alt-B, as suggested by Rick.

image

Tried using Alt-B and Alt-J and got this result, not sure why the fill doesn’t show up in the workspace.

I have some needed answers if possible.

  1. Do the enlarged nodes have any intended purpose?
  2. Is there a way to find 'un-joined segments (nodes) other than individually searching each node?
  3. How does one post a LightBurn file?