Problems with mouse when dragging across screen

Hi
I have just upgraded my PC, which has made me update Lightburn for the first time since last year (was working fine so didn’t bother to update to version 1+). I am now having issues when I left click on my mouse and drag across the screen to select all of the file that is open on the screen.

In the older version of Lightburn whenever I left clicked my mouse and dragged the cursor across the screen and I hit the boundary of my work area (900 x 600) the arrow stopped, like it hit a wall, and the screen stayed central. However now since I have updated the arrow will carry on, meaning that I can scroll way off the screen. I am having to recentre my screen all the time, which is slowing my workflow down.

Is there any way to stop the arrow carrying my outside my chosen work area?

TIA

This appears to be normal behavior, not sure if you can disable this as it’s more likely a system software feature rather than Lightburn. As a work-around you can select everything using ctrl+a (cmd-a) or zoom out with the mouse wheel then drag select. Is there something specific where this causes an issue?

No, there is not. We added auto-scroll to the drag selection to assist in the selection process. @stixstudios suggestion for selecting everything on your workspace is a good option. We have several ways to accomplish what you want. The following is worth review: Zooming, Panning, Selection - LightBurn Software Documentation

@Rick Thanks for your reply. That’s a shame. Using the keyboard isn’t an option most of the time, as I just use the mouse to load my files and send to the laser. I will have a read of the links you suggested to see if they offer a workable solution. No chance of offering an option to turn off auto-scroll in the future?

@stixstudios Thanks for taking the time to reply. Using the keyboard isn’t an option most of the time, as I just use the mouse to load my files and send to the laser. It causes an issue every time I finish one cut and move onto the next one.

If you can’t use the keyboard, this button is “Zoom to Page” which restores the framing to the way it was when LightBurn was loaded:
image

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.