Problems with offset fill

Can any one help with this offset fill problem i will attach a photo. Belts and wheels seem fine ordinary fill and cut are good

Most likely, the movement of Offset Fills is inducing a mechanical error that you’re not seeing with Fill or Line mode. I would give your mechanical set up another once over if you need to use Offset Fill - Check to make sure your belts are tight, the wheels are not snagging anywhere, the laser head is mounted firmly and not wobbling, all your stepper pinions are snug, none of the set screws are loose, and that there is no dirt or debris on the rails. With your machine off, you should be able to roll the laser head smoothly across the rails.

With that said - the graphics you’re engraving don’t fall within the normal use-case of Offset Fill. Offset Fill is generally meant for saving time engraving graphics with large hollow spaces. Regular Fill is probably better for what you’re doing here.

1 Like

Cleaned wheels and adjusted belts checked all else. Cuts perfect circle that you can rotate in it self. Did a circle and gave it an offset of 2mm and used the offset fill to engrave it. Same thing happened leaving a small gap.
I notice that the laser turns off at that point. Could this be my problem. And how would I fix it.
Many thanks for the help much appreciated

If the laser is turning off, leaving a gap, that could be a power supply issue. The same video I sent yesterday has a section on power supply problems:

If you share your test file here, I’d be happy to take a look at your settings as well, although I think it’s unlikely they’re the cause.

The M4 dynamic mode will be scaling the power down in the corners but the laser may not be outputting that scale as expected?

If you change to ‘Constant Power Mode’, do you see any difference?


Thanks for the suggestion i did what Nicholast said and this was the outcome in the photo any more suggestions welcome thanks for the help

Ok, switch ‘Constant Power Mode’ off again.

That confirms to me that the motion is OK, but the power scale is far too light at the light end when in M4 mode as the laser slows for direction changes.

If your laser’s machine settings allow you to increase the minimum PWM duty cycle - that might help lift the low end of your laser scale:

However, not all GRBL controllers are configured to allow that level of control, probably most (including yours) do not.

In which case you will be better off to use a regular fill as @JTR suggested, it may also help to enable overscan so the speed over the burn area is more consistent.

What does 40mm text look like when etched/in line mode?, are the tight corners being marked at the same strength?, do the start and finish points line up? (overcut may help if they don’t).

my latest photo

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.