Problems with origin at startup

Hello,
Every time, when starting I have different values from 0 to “Get Position”. If I use “Go To Origin”, the Laser will move to the left front, hit the frame.
Every time start I have to follow a few steps that make me tired. I have Right click “Get Position”, the values are copied to “Move to Position”, then “Go” / “Set Origin”. Is exhausting. What settings need to be made so that the “Get Position” values are zero at each start?
When I first used this software, I remember it didn’t happen that way.
I mention that I have a laser machine DIY GRBL
Thanks for understanding.

Does your machine have limit switches installed, and do you use homing? If not, your machine zero will be wherever the head was when you power it up, because the machine has no idea where it is.

It has no limit switches, after starting it if I use “Go to Position”, it goes to the left front and hits the metal frame. I cannot start the machine with my head close to the limit. Basically, it always starts from the coordinates X = 20 and Y = 10, not from absolute zero. At first it did not manifest itself in this way.

Why are you using ‘go to position’?

Without limit switches or homing your machine has no frame of reference, and therefore will not be able to use any form of absolute positioning. You might be able to fake it by moving the laser head to the front left of the machine before you power up.

Why? You’re right, it’s not very necessary, but this problem has recently emerged. It is definitely a problem somewhere.

I mean why are you using it? What are you hoping to achieve?

I have a extra care now. Every time I start the machine, I have to set the origin. I can not base on the starting position because it takes me out of the workspace. If I press the “Get on Position” button, the head is moved on X = -20mm, Y = -10mm axes. I reinstalled the “grbl_v1.1f.20170801.hex” firmware and the LightBurn software. The same problem appears on the LaserGRBL software (here the starting position is at X = 20mm; Y = 20mm. It is a little annoying.
Is there no solution to this problem?

The solution is to install limit switches and enable homing. Without that, the machine has no idea where it is. You can issue a command to force zero to be anywhere you like, but you have to move the head there and run the command (G92 X0 Y0 I believe)

I tried G0 X0 Y0 and G92 X0 Y0. The values from “Get Position” were reset to zero, but at the next start they were not saved. I succeeded with the software received from the Chinese seller. It helps me upload the settings to the original or modified settings and upload firmware. Now at start I have to “Get Position” all the zero values.
Thanks for the help and the speed of the answers.