Problems with Ortur Laser Master 2 connecting and engraving from Lightburn

So I received my laser master 2 a couple of months ago, and it worked great with my first software, Lasergrbl. I decided to buy Lightburn because its supposedly the best for engraving/ cutting machines. A couple of days ago, I was trying to engrave and the Ortur would not connect to Lightburn. it would shut down whenever it received information, and it would not auto home on startup. I have tried everything I know how to do, but I’m only fourteen and I need help from the professionals. Any help is welcome :+1:

Did LightBurn find the laser using the ‘Find my Laser’ tool? If so, you likely just need to choose the COM port to connect to.

Power the laser first, then start LightBurn. Then choose the COM port (read here: and look in the Console window to see if you get connection messages and output from the controller.

Post back with your results once you’ve gone that far.

Waiting for connection…
[AUTHOR: RenShen]
[MODEL: Ortur Laser Master 2]
[OLF: 137]
[DATE:01:15:16 - Apr 20 2020]
Target buffer size found

This is what happens when I do what you said…It also says “busy” and “100%”.
And it connected, but I had to remove all devices and then do “find my laser”. Also, only the red light on the Ortur stays on. It is not homing or moving at all; the laser is not responding to anything.

When it says “Homing” is the machine moving or doing anything? The Ortur homes itself when powered up (mine does at least) so you can likely turn off the Auto-home on startup setting, though that shouldn’t hurt anything if the machine has finished homing when you connect.

Once it’s homed, the busy bar should go away. Does it not? (Make sure the machine is actually powered, not just plugged in via USB. You have to hold the button down long enough to power it up.

The machine only moves when I first start it up. It does not respond to Lightburn’s “home” button. The busy bar does not go away when it is homed, and it is powered and plugged in via usb. I am holding down the button long enough as well.

I would go back through the device setup and remove the auto-home. Click the Devices button, double click your laser in the list, click Next until you get to the page with the Auto-home option and turn that off. It’s possible that it is conflicting with the Ortur automatic homing.

I did what you said and it actually started up this time, but after half of my test hexagon, it disconnected and quit. I did this multiple times with multiple shapes, but the Ortur disconnected and quit roughly halfway through each of the shapes. But at least the diode started up this time, and it homes now(with the lightburn button) when it is not “busy”.

Check the USB cable connections on both ends, and possibly try a different cable than the one supplied with the Ortur. It’s been pretty common for them to disconnect. You might also try installing the software supplied with the machine, and more specifically the driver included - I’ve heard from some people that the default Windows driver works, but once they installed the actual Ortur driver that disconnections stopped happening.

The cable does not seem to be the issue because the problem is still there even with a different cable. Also, where is the best place to download the Ortur driver/software?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.