Problems with svg files since latest update. It is Easier just to show you

never mind. I had to wait. :slight_smile:

Math going wacky. :slight_smile:

the rollback fixed the problem. Do you want me to send you anything?

Now i am mega puzzled.
Any chance you could post your export SVG from 1.5.06?

ROLLBACK TEST

Hi,

I’ve escalated this issue up to our Dev team for review. Thanks for letting us know!

Great! Thank you for the instant help. Fastest tech support I ever experienced. Until then I am sure I will be able to be fine with this version. Thank you again. :slight_smile:

1 Like

We aim to please :slight_smile:

1 Like

It is obvious. Always coming out with new features and updates. You guys are on it. No competition. Thanks again.

1 Like

This does indeed look to be a bug. It was discovered a while ago that SVG files apply the scale of a shape to the stroke width, so if you scaled a shape down, the stroke got very thin (and in some cases basically invisible). I added code to correct that, however mirroring a shape is “scaling” it too - by a negative number.

Short version: math things made the stroke width scale up really huge when scaled by a negative shape scale. I’ve fixed this, so let me know if this exported version of your file looks correct if you download it and open it in Illustrator:

Test2

3 Likes

This file that you uploaded worked fine in illustrator and maintained all of the layers. :slight_smile:

3 Likes

Hello, Here is the .SVG file that I exported from lightburn 1.7.00
It is much better but it has added some layers of squares mostly under the mask template. They are visible in adobe Illustrator and they show up as well when you import the svg into lightburn. They show up in the BLACK layer. If you need anymore info or assistance just let me know. Thank you.
new test new version of lightburn

You had one file here in this thread (post 25) where they’re visible as well. If I export your LightBurn file that you uploaded in the 5th post, I don’t see the rectangles. Can you double check that those rectangles aren’t in your source file?

1 Like

They sure are there. :slight_smile: Sorry for steering you in the wrong direction. First time I checked I did not see them before I reported it. I had that layers visibility turned off. DOH!

2 Likes

I just tried it on my lightburn (1.6.00) and I exported it as an SVG and brought it into Adobe Illustrator (part of CC but it is version 28.5) and I had ZERO issues.

Very good Defcon, Glad you are not having any troubles. What ever was going on the programmers at lightburn were able to find the bug and fix it for a future version so it does not happen to anyone. Thank you for your input.