Putting Lightburn back into rebuilt PC

I have 2 PCs both with Lightburn, one failed, repaired but could not reload Lightburn.
only beginner version, tried licence #s no success
Help urgent.

Can you describe where exactly you’re having trouble with the reinstall? What exactly happens when you attempt to enter the license?

If this is just a license management issue you can get more information here:
Manage your License Activations with the License Portal – LightBurn Software

Other thing to consider is are you licensed for the version of LightBurn you are trying to install?

Also, beginner version is a mode, not a license type. You can turn off beginner mode in Edit->Settings.

I download Lightburn and get to the page to enter for trial period and don’t know where to enter my existing license #, to get back into the program.

Detailed first run information is found here:
First Run - LightBurn Software Documentation

But specifically, you need to put your license key into the highlighted field here and then press “Activate License”.

However, since you’re installing this onto a new computer, you may run into the issue that your license is still active on your old computer. If so, you will need to go to the license management site that I sent in the previous message to first remove the activation on the other computer.

If this doesn’t work, please send a screenshot of what you’re facing.

I’m not having any success.
I have two computers each with Lightburn on with licenses.
One computer had problems and in repairs software was erased including Lightburn. On restart and reloading all necessary stuff, Lightburn was downloaded but I can get past the license page. No matter what license # I enter. Each # I try is not accepted. Help,

Can you send a screenshot of whatever you are saying shows “not accepted”?

There are a number of still open questions from previous replies. Can you answer them?

  1. Are you licensed for the version you are trying to install? (what version are you trying to install?)
  2. Did you visit the license management site to free-up the license from the downed computer? This may not be necessary depending on what was changed on the repaired system.
  3. Additionally, are you certain that the license keys you are using are the correct ones?

(removed license key image)

Hope this helps, I thought there was only one version, attached are license info.
Really appreciate your help, I’m a little slow on the computing stuff, thanks again
David L

“Not having success” - what does that mean, exactly? Are you getting an error of some kind? If so, can you share what the error message is so we can tell what actual problem you’re encountering?

When you tell us that you can’t do something, that doesn’t provide any information about why you couldn’t do it. For example, if I said, “I tried to drive to work today, but didn’t have any success” you can’t tell if I couldn’t get into the car, couldn’t start it, crashed, was out of gas, or don’t have arms.

If I said, “I was unable to start my car this morning and kept getting a red light that looked like a gas pump on the dashboard” pretty much anyone could tell you what I did wrong from that.

Provide as many specific details as you can.

It’s also a very bad idea to post your license key on a public forum where anyone could grab it.

As I have mentioned, I am trying to load Lightburn back into my pc ,that was repaired.
All applications were deleted including the original Lightburn .
On restarting and loading all the apps I use, when I reloaded Lightburn and started it, the License page screen appeared and I guess required some input to continue. I tried all the Id’s that I have and cant get beyond this page. I need help as to what I should do or what should I enter.
In my other PC, Lightburn works OK. Thanks again.

Can you send a screenshot of what happens after you enter your license information and press “Activate License”? Please exclude your actual license key.

Right now it seems that the problem is that you can’t get beyond that point. But we have nothing to provide a remedy for as it’s not apparent what problem scenario is presented when you press Activate License.

Whatever license # I enter, the reply is wrong ID #

After entering #, Screen says “invalid license key” then pressing OK, screen reads" License activation failed, be sure your license key is correct"

How are you entering the license information? Are you using copy-paste from the original license email? It needs to be entered EXACTLY as it’s given, including capital letters and dashes.

I have entered both of the License #s and double checked them.
Can some one check to see if my Licenses are still valid, I have checked and it says they are both valid to Jan and Feb 2022.

I double checked the ID #, after printing them out from what was on the screen, but the screen did not show all the ID #s so my printout did not show me the exact ID #.
Which was what I was using as reference to save going from screen to screen.
Going back into the checking of the # validation I copied the # and pasted it, then noticed that there were 5 more digits added to the #.
Now the app works ok.
Thank you for all your efforts
Lightburn is the best of the best.

That’s great that you’re back in business. A little effort but hopefully that makes it sweeter.


The error message text is very specific - If you get “invalid key” it means exactly that - the key was not valid, which is usually entered incorrectly. There are different error codes for things like network trouble, too many computers on the key, and so on, so including the exact text of the message is important.

Happy to hear you’re up and running again.

Thanks for all uour help, learned a bit too. Stay safe

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.