PWM Issue on SKR Mini E3 V3

Hey all - been tinkering with a new laser setup on my RigidBot 3D printer which I added this 24V laser to and running the SKR Mini E3 V3

It has a 3pin configuration (24V+, GND, PWM) and I can’t seem to get the PWM working. The only thing that I got to work for a bit is hooking 24V+ and ground up to my fan1 port (PIN PC 7) with no connection to the PWM cable, but I think the power of this laser fried the MOSFET on because it’s now stuck at 24V, although it did cut for a moment.

After that I tried assigning PWM to to a 5V pin since this laser support 0-5V 0-12V PWM signal so I tried assigning PA1 and PC14 (from Z-Probe which I don’t use) to the PWM but they did not work, I can’t seem to control them as PWM even though others have indicated they are PWM capable.

I also noticed this laser if connected to constant 24V will always fire 100% even without PWM cable connected. Wasn’t expecting that, so not sure if something is wrong.

Appreciate any insights, this is starting to drive me mad!

Looking at github with this board, I see nowhere they suggest it can be used with a laser…

Can you post where the pwm is supposed to originate for using this with a laser module?

Most of the information is more like the pinout of the cpu rather than usable outputs for laser controls…


I’ve got 24v power to the laser so the PWM cable is the only question. I don’t believe the board cares what hardware is attached as it’s just blindly supplying the PWM signal right? I think the issue is that the it expects a 0-5 or 0-12V PWM signal and the fans are 24V so maybe I just need to use a buck converter unless there is a different 5V PWM capable pin?

I see no indication that the board actually produces a pwm signal or from which pin, where are you finding the documentation on this? Not to mention, of the github I’ve look there is no mention of using a laser module.

Most boards work without being in the machine, so that’s not relevant unless there are some type of protection pins that need to be satisfied.

Help me with what you have to do to change the pwm pin or anything to do with using a laser module…

Most of these are based on a ttl level (0 - 5V) pwm signal, but almost all will take 0 - 12V on that pin. It’s still considered on over about 2.5V even with a 12V signal.

Don’t complicate this any more than it is… you shouldn’t need to add this kind of stuff.


Sorry - the PWM info for the board I can find is here.

It shows 5 (3 fans, heated bed, hot end). I had a fan open which is why I was trying to use that signal.

OK so just an update from last night. I was able to assign an open digital pin to the PWM and get it working but the logic on this board is all 3.3V and I need 0-5 or 0-12 so it’s running at reduced power. Reading up on similar issues it seems like I need to either get a logic level shifter to go from 3.3V → 5V or a buck converter to shift the 24V signal to 12V. Does that sound right to anyone?

It will work or it won’t, so how do you figure it’s at reduced power?

So it should work fine with your board… A pwm high value of 3.3V will turn the laser on properly.


good point - I am really new to all of this and get the concepts mixed up but yes I understand that if it is firing the signal is working. It seems to be at reduced power just based on how it’s cutting/burning relative to before when I skipped the PWM wire and used the fan port as a PWM on the ground wire. I’m going to tinker with it this afternoon and see if maybe it is the firmware or software settings since I’m also running it using G03/G05 now and was previously using M106/M107. Appreciate the support and patience. While the tinkering has been a bit frustrating I am actually learning a lot which is fun.

A solid state diode laser is ether off or on. 50% power is really power/time or it’s on for half the time, then off the other half.

The only explanation for this is that Lightburn is incorrectly setup. Such as a mismatch with the Maximum spindle value ($30) and Lightburn S-Value Max.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.