PWM spindle is not enabled

I updated the firmware of the MKS DLC32 controller to the latest version of (V2.30_H35_2022_1223_N_ZX_001), after that I pressed the “spindle” option on the touch-screen attached to the controller. Then, when I try to engrave/cut with the laser, there’s no more laser coming out and I got this error ([MSG:M4 requires laser mode or a reversable spindle]
Unsupported or invalid g-code command found in block.
On or near line 2:).

I tried to figure it out by myself, I set the PWM frequency to 1kHz and I got this message ([MSG:PWM spindle Output:GPIO(32), Enbl:None, Dir:None, Freq:1000Hz, Res:16bits]), where I noticed that Enbl and Dir are not defined.

So how can I fix it up if any one can help please.

please note that the laser is working when I try to frame any shape.

You probably didn’t set $32=1 That might create the first error.

You should only set the PWM frequency yourself if you know that your laser head has a specific one.
I suggest resetting the firmware settings and set $32=1. Then try again.

It’s is already on, check the following settings





















































One of the reasons you get no beam is because $30 is set to 10,000. Set it to 1,000. Usually, most control software use 1000 as a maximum s-value.

Also, make sure you didn’t enable gcode clustering in the device settings. Though I don’t think that’s the issue here.

Maybe also try to go one firmware version back, I think I read a few reports that the latest version has some bugs. But I don’t recall exactly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.