Question about LEAD IN

hi i’m new,
I have a 300w laser and I cut a lot of metal,
so I’m very interested in using the Lead In,
I would like to know if in a rectangle, it is possible to put in Lead In in the middle of a side,
I tried but I can only move it to one of the 4 corners

it would also be very useful to be able to see on the drawing where the various Lead In are positioned,
instead they are only seen in the preview,
so to see if they are positioned correctly you have to open the preview really many times
Thanks in advance

I just tried to add another node mid-side, and assign that node as the Start point of the shape. I am not able to change the Lead-in to the node as I’d expect. Thank you for reporting this. We are investigating and will update when we know more.

Further, I notice this is happening on straight line segments as I can place the Lead-in where I’d like on curved shapes.

Which OS and version of LightBurn?

OK thanks,
I found how to put a new no and set that as a starting point,
but I had to disable “Optimize cutting paths” in the laser window,
because if not some points did not take them into consideration, ignores them,
it would be convenient as in the MetalCut software to be able to insert Leads
by clicking directly on the desired position and leaving them visible on the drawing,
it would be very useful, fast and pleasant.

i have windows 8.1
and latest LightBurn version 0.9.22

I just tried every combination of lead-in, start point, start direction, turning optimisation on and off and got the same thing - a rectangle starts from the corner every time, and no lead-in, no matter how many nodes in the line.

If I offset the mid-line node, by even 0.001mm, it starts where I expect it to. Which is a fudgey workaround, but may help. Still no angle lead-in, though - but I may be setting my lead-in wrong.

Mac Mojave ver 0.9.23

Thanks Bo, I think Oz is tracking this currently. For the angle entry,

And you can use negative numbers.

This is one of the reasons we support Lead-ins, Lead-outs, Delays and Cut Through options. We are putting the base elements in place for further product developments. Not fully supporting all required ‘Metal Cutting’ options just yet. That will take time. :wink:

I did change it, but didn’t see any change in the path - but I did only have it set to 15deg.

When I set it to 45deg, either positive or negative, exactly the same behaviour. You can see from the traversal move line that it’s not leading in.

Hmm, here is what I get.

These are @ 45º and 10mm long in this view.

And these flipped to -45º

I must be doing something very wrong - I don’t get any indication of lead-in, no matter what settings I use. I just changed the part point to a corner, as you have, and still nowt.

I don’t actually need or use lead-in/lead-out, just interested in the problem.

Just checking, but did you assign a length and flip the button On? Show the Advance tab for that layer, I might catch something.

Screen Shot 2021-04-02 at 1.11.30 PM !

As you can see, nothing on traversal or cutting line


You need to add a number, LightBurn is doing what you have asked. :slight_smile: Create a Lead-in, at -45º, and make it Zero length.

Thats it - 0 length. The panel is non-intuitive - I though the length entry was for the lead-out, as it sits next to it, or for line vs arc.

I’ll go back through my checks and see if it changes.

Understood. I don’t know what additional information Oz has planned for that panel, but maybe could move these to side-by-side.

Curiouser and curiouser said Alice…

No matter what I set the direction to when using the set shape start tool, it always goes the same left-to-right direction, with optimisation set on or off.

You can see the direction is set to right-to-left, but the motion preview always goes left-to-right.

You can see form the traverse move that the motion starts on the right, as is normal on my config.

Yep, part of the issue being looked at currently.

Cool - unrelated while you’re here - what does ‘shift’ at application launch do - I can’t find it in docs.

Resets the Window Layout. Right-click ‘Devices’ should re-establish communication with the controller.

We will be working that hard over the next few to fill out the new docs with a bit more.

1 Like

This trick actually works for at least one or two others as well, like the Preview window. If you had previously used it on a dual monitor setup, then disconnected one, if the saved position to restore ends up putting it off screen you can Shift+Open to ignore the saved position.

1 Like

This is now fixed and will be in the next release, which I’m targeting for early next week. It was a result of a degenerate line remover not respecting the user generated start point. If you just inserted a new point the system got a little trigger happy and helpfully removed it for you. It will now do all the other degenerate points, but not any tagged as the starting point.