Question on frequency (50w MOPA jpt)

Really really appreciate this forum… I’m completely new to all this lol.

My understanding when looking up the settings for my laser source (50W JPT LP) is that the frequency range is 1-600 khz, so that’s what I set it to in the settings. But then when I go to actually engrave something those settings max out at 80 khz and won’t let me go above it. Does anyone know why?

Try toggling on ‘Enable Q-Pulse Width Setting’ - you should then be able to increase Frequency all the way up to 600.

1 Like

Try changing the fiber type YDFLP. Might have to power cycle after changing settings. With my M7 the JPT setting did about what you are describing.

1 Like

Isn’t really a solution …

From this manual

The standard pulse width is 200ns for YDFLP-E-20&30-LP-S and YDFLP-E-50-LP-L. Other pulse width is available for customization request.


Why I bought the M7 … :face_with_spiral_eyes:

:smile_cat:

1 Like

Yep, that’s why I suggested changing the fiber type. +1 for the M7!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.