Question regarding power and speed adjustment on the fly

I have tried pausing a run and in the “Cuts / Layer” settings making changes then resuming. This does not seem to have any affect.
I am doing this to see what may give me the best results without having to run a whole other job again.
I found I can go to the “Move” Tab and make changes on the fly, but this is in a percentage and is not in an exact number.
I want to know the setting exactly. If power is 50% and I reduce it by 10% What is the setting now? I am no mathematician by any stretch of the imagination. I can figure the speed setting adjusted by a percentage; this is more straight numbers.

Is the percentage change by the original number or of the number it is changed to if changed multiple times?

Once a job has been started, it’s completely cached and changes have no effect. If you have this case a lot, try different strategies like using multiple layers or passes.

Its 45% then. If you press it again, it’s 40.5%. I guess that doesn’t really matter because fractions of a full percent are not really noticeable.

I don’t know if this is a bug, I noticed when going to the Move tab and adjust the speed percentage, the power percentage changes as well.

That sounds like a bug, those shouldn’t interfere. Edit: I just tested with 1.6.02 (still had it running) and new install of 1.6.03 and experienced the same.

@LightBurn @JohnJohn could you have a look?

lb_movebug

This is not a bug. If you use variable power (M4) the power is varied by the speed of the laser, so changing the movement speed will also affect the laser output. It’s how the firmware works, and we have no control over this.

1 Like

I hope to be as knowledgeable as you someday. :thinking:
Like that will ever happen. :wink:

Thank you.

I wrote the code, so I have to understand it, at least once. :slight_smile:

3 Likes

Ok, thanks. Then this is still a minor UI bug, since in M3 mode (turn on constant power in layer settings) the power numbers are still increased in the GUI, but not in reality. I just tested this behavior and it’s incorrect. For dynamic mode (turn off constant power), it’s correct.
I don’t think it’s critical, though I’d put this onto the ToDo list for bug fixes :slight_smile:

I will add a video as soon as it’s finished.

Edit: Here it is. It was a very quick recording and hopefully, you can see it (set it to HD quality). I used my laser simulator that analyses the PWM signal that is coming from the mainboard. In the first try, I disabled constant power, and you can see that power increases while increasing the speed (the little black display below). (Power was set to 50%, so each increment is 5%)
The second attempt is turning on constant power, and then UI behavior is wrong. You see the percentage at the power is increasing, but it does not increase physically.

I have no way of knowing whether the controller is in M3 or M4 mode, since those can be set per layer, and the controller has an arbitrary amount of buffer between when the command is sent and when it’s processed.

Even the displayed percentage numbers are guesses, because different GRBL implementations could use different step sizes, or have different clamp limits. I’m honestly tempted to remove this feature - we have to field a lot of complaints over it, but the limitations are all to do with the firmware and have little to do with LightBurn.

Absolutely true. I should have called it a limitation instead of bug. :slight_smile: I would love to see a new “grbl 2.0” implementation that gets rid of most current shortcomings, but I think that’s nearly impossible regarding the grbl laser market and number of derivates and “manufacturers editions” :slight_smile: The current successors have potential but issues as well.