Questions about PWM and Neje 30W controller board

My laser NEJE 30w no longer works with lightburn. It has a small controller board that goes between the Arduino CNC and the laser… The button on the controlller board will fire the laser. However, using the fire button in LightBurns move tab or sending a job to the engraver the laser does not fire at all, I have replaced both the arduino duo and the cnc shield with no results.

  1. Which pin is the PWM +z or -z endstop. (running grbl 1.1) ?

  2. if hook up a voltmeter to pwm and the ground should irt register any current when the laswer is fired through lightburn?
    I strongly suspect the controller board needs replacing. However, if it is not recieving the PWM then the problem is else where.

The black goes to the PWM and the yellow goes to the ground

Didn’t know you lost the Z limits in exchange for a pwm… that doesn’t sound right…


You can measure the pwm by using a regular meter. It will display 50% of the voltage (ttl, 5V) at 50% pwm… 20% pwm, 20% of the ttl voltage.

Laser doesn’t need power, just the controller…

Make sense?

:smile_cat:

Yes, it does make sense. When I attach the PWM to a volt meter I get no reading at all. Since I replaced both the Arduno Uno and the grbl cnc shield I doubt the problem lies there. If the PWM is not sending any sginal then I would expect the laser not to fire. So the control board for the laser appears not to be the problem, The only thing I can think of is the wiring to the pwm ground is not correct.

As a side note the controller board with just the 12v connected No ground, still fires the laser by pressing the test button on the controller board. Seems strange to me

If you get no pwm activity, that is generated by the controller and I’d say you have an issue there. The test button on these just pulls the pwm line high… causing it to lase, same as the controller would do…


I assume you checked the pwm at different percentage settings?

Usually you can check at 50% for 1/2 the voltage or 100% for full voltage.

If there isn’t a ‘circuit’ it can’t work, so I don’t follow you here…

:smile_cat:

At 100% the voltage for the PWM is .7 volts. That seems low but I have no idea what it should be.
.

Did it ever work?

As someone who fixes this stuff, save yourself time/trouble by identifying the probable cause before swapping out things. It’s easy to add human error to the mix making it even more of a puzzle…

Once you do that, knowing it ‘worked before’ is not too much help…


This will not be enough voltage for the laser to fire.

The pwm should reflect the percentage of voltage… 5V signal at 50% pwm will read 2.5V… 80% 4V… etc.


It’s a ‘ttl’ input, usually means a 0 to 5V signal. I know my N40630 Neje laser module will take up to 12V on the ttl inputs.

If you notice, it takes at least 3.3V to turn it on…

I’d suggest measuring the pwm signal without laser ‘driver’ board.
Unplug the cable at the Arduino shield or laser module and measure it there…

Maybe the optical isolator on the driver is bad…

Good luck

:smile_cat:

Okay here is what I found out. When not connected to controller board the pwm registers ~5 volts at 100%. When it is connected pwm registers at .7 volts. This leads me to believe the controller board has failed. I am going to order one from amazon but it will take 4-6 weeks to get here.

Thank you so much for your input and information.

I assume you mean when the laser module is not connected to the controller and the pwm (power) is set at 100% the pwm line reads 5V…

What is it at 50% pwm?

This tells me the controller is working… maybe I’m confused…

:smile_cat:

No, when the pwm line is NOT connected to the controller the line reads 5V. When the PWM line is connected to the controller pwm line reads .7 volts. I have not tried disconnecting the laser from the controller.

You need to measure the output of the controller, with/without the laser module.

How did you measure and where ?


It’s quite simple, unplug the laser module and run a job at 100%, measure the pwm. Run another job at 50% and measure the pwm voltage.

If it’s 5V at 100% and 2.5V at 50% the controller is working.

:smile_cat:

Jack, thank you for all your help… I kept getting inconsitent PWM readings on my multimeter none of which responded to pwm settings on Lightburn. I decided to switch to a ramps 1.4 on a Mega 2560 running Marlin. The laser is now working. It appears the problem was the Arduino Uno,
Again thank you for the time and all or the suggestions and if you celebrate have a happy thanks giving.