Rail crashing after update

I have an S9 with an S10 10 watt laser head. And limit switches that I added. The homing was working great until I did the Lightburn update. Now it doesn’t home - it just grinds against the rail. Any suggestions on how to fix it?

The update to 1.4.00 should preserve Machine settings.

Zoom out if necessary to put the whole work area on the screen. Then screen-capture the work area and the ‘Device Settings’. Click Edit then Device Settings then use a screen capture tool like the one below:

Capture your whole LightBurn Work area and the Device settings.

It should look like this:

Even better if you have a project going already.

Then, in the console window, ask the sculpfun for a few reports by typing:
pressing enter after each one.

Please mouse over to the console window and select those reports, and copy & paste them into a reply here.

This should show us if any of the settings have gone awry.

Any other customizations or replacement parts with the Sculpfun device?

Where does it hit into the rail? Where it should home or in another direction?

John is right, LightBurn has nothing to do with homing, it only sends the command to do so. Everything else is handled by the laser. So, it’s most likely a broken firmware settings. Post the output of $$ as John mentioned.

It is set to home in the bottom left corner. It was crashing into the bottom rail. I think I fixed it thought - I know not to move the laser head by hand but I went ahead and moved it to the middle and then hit the home button and it’s working now. If it continues, I will reinstall the firmware. Thanks for your reply!

1 Like