Random lines engraving that shouldn’t

Laser jumping around


Is flood fill turned on? turn it off.

Hi hank, the flood is turned off. I thought it might be that too but no luck.

Are you tracing a vector? I had this same problem in the software by not setting the threshold properly on the trace. Now before I send any job, I go to the preview with traversal on (to see the path of the laser) and play the entire burn. I have had to go back and retrace several jobs, but it hasn’t happened since.

I am importing a svg and going from there or sometimes I trace a png but I don’t understand the threshold feature or what that correlates too. I will play the preview and in the preview there are no issues showing or jumping laser. What do you set your threshold at? And did you also have the issue of extra lines and/or the laser moving around?

Here’s an image of the controller. I will look it up and see what I can find

RD KT322N it is

So, I’m running Windows and use the usb cord provided with my machine. I posted video that shows the extra lines and how the laser willsometimes redirect in the middle of a job and then return to what it was previously doing. In lightburn my controller is listed as ruida 644xg and inside the electrical panel I see it is a kt332n I came across some other threads and saw several people with the exact same controller having issues with connections and get the message failure to send. I also get that message frequently but then I resend and then they data goes through. But seeing all those other people with my same controller comment about the connection issue is making me wonder if my other issues are all related. And if so, what would be the step to take? See if there’s a firmware update for my controller? Revert to an old form of light burn?

I’m not sure if it will help or if the kt322n is listed individually, but going in and redefining your machine could be useful.

No need to delete your current settings just add another machine setting.

Those more experienced will add if it’s likely to help, but in the interim you could try it.

Good luck


I have one of these controllers here, so I’ll get it wired up and in a machine so I can try to reproduce this. Can you give me a bit of info on your computer? If you go to the Windows ‘About your PC’ page, what does it say?

This is mine:

1 Like

Hi Oz,
Ok, so i downloaded the version of lightburn you suggested and but I still had lines and the laser moving to other places like i described before. It would work without any problems for hours and then suddenly it would mess up. To be clear I was making coasters, all the exact same design. I made 6 without issue and then number 7 messed up, but number 8 was good. Here are my laptop specs

|Processor|Intel(R) Core™ i7-5500U CPU @ 2.40GHz 2.40 GHz|
|Installed RAM|8.00 GB|
|Device ID|5BDEFE65-5F50-47D5-8058-EA2F0ADC5A65|
|Product ID|00325-95837-18600-AAOEM|
|System type|64-bit operating system, x64-based processor|
|Pen and touch|Touch support with 10 touch points|

How do i send files to you?

I’m trying to attach some svg files I’ve used but it doesn’t seem I am allowed to upload svgs.

Oz, should I send a different file type? I have really only been using svgs though so I haven’t even tried it with other types. Maybe I should. Maybe that’s the problem?

You can send to support@lightburnsoftware.com, and include a link to this post for context.

Oh, doh! Thank you!!

I’m having the same issue. I only updated to 9.24 recently as I had read about the bugs so held off.
This is the first file I’ve saved as lbrn2 format and sent to the laser (others have been lbrn files that were already saved - I just open, add the name and engrave without saving)

It has skipped random sections and added random lines too.
I’ve engraved hundreds of items with my current setup and never had this problem once.

Ruida RDC6442s-B
using the USB cord that came with the laser (has the ‘chokes’ as pictured earlier in this thread)
Hitting Start from LB, not Send.

This is an svg file imported into LB

I’ve just created the file from the svg again, did not save it and ran it from LB as before and it’s fine - no random lines.

Could you possibly send me a link to the ESP32 code and config you are running please I’d like to try it out.


I’m a novice and i don’t know what the esp32 code is. Where would I find that? I am using a ruida controller, though technically it’s a ryxon but is recognized as a ruida in lighburn.

Hi, I’m sorry you’ve been having this problem as well - it’s so frustrating! I also use the usb cord with the chokes that came with the machine. What type of machine are you using? My lines are really inconsistent so it’s hard to know when it’s fixed or not.

What do you mean that you created the svg file but didn’t save it? You’re importing it and then running directly from lightburn by hitting start or are you sending it and then hitting start?

It is frustrating, and I can’t afford to be wasting pre-made plaques on it.
I have seen a few other people commenting on the various facebook groups with very similar looking issues too.

Usually I open Lightburn from the Windows menu (not an existing file)
Import the monogram as an svg file
Add the name to it
Hit start to run directly from Lightburn (not send to the laser)
I don’t save the file, just exit Lightburn without saving

I have also done the above, and saved as lbrn (legacy format)
then gone out to my laser, open the saved lbrn file and hit start to run from the laser.

These methods have worked perfectly hundreds of times.

When I got the random lines I imported the svg file, added the name, but saved as lbrn2 format instead of lbrn.
I went to out to my laser, opened the saved lbrn2 file and hit start to run from lightburn.

I’ve gone back to my original methods and will not be saving as lbrn2 file type.