Random lines engraving that shouldn’t

Hi, struggling to understand why the laser will engrave random lines when it is moving between objects as if the laser isn’t shutting off when it is moving to the next segment. it isn’t consistent though. I’ll run an job and get these random lines but then run the same image again without changing anything and there are no random lines at all. No rhyme or reason to it. Anyone know what this is about. For reference I have a 50w Chinese laser and am running it at 20power, 250 speed, using svgs on fill. Attaching pic for help. Also attaching my controller which is recognized by lightburn as ruida controller but apparently there’s some dispute about whether it’sa true ruida.

Ohhh yes the min power was set to twenty. I didn’t realize they should be set differently. I guessing don’t understand what the minimum power is for. If that is the problem is that something that would cause problems so inconsistently? Like sometimes there are no issues at all. Thank you so much for responding!!!

I am not sure min power is related to diode lasers i use it when i burn grayscale on my blue laser so my whites are slightly burned and not just original material untouched. When cutting i set mine to zero.

Here is a pretty informative video i found awhile back on min power that might be helpful to you if you have a c02 laser its more important to get the right setting. It would seem intermittent since 20 percent in some materials may not be enough to make a mark while in others like your pictures it is really visible.

https://www.youtube.com/watch?v=pjud3FHn9H4

Ok, I will try adjusting the minimum power and see if that makes a difference. Thanks for the video!

Do you have a blue diode laser or a c02 laser?

It’s a co2 laser, sorry I should’ve clarified. It’sa Chinese 50w I bought from ebay

Yes for C02 laser you certainly want to figure out min power, you could jog the machine to a spot on a piece of wood and use the fire button in LB, start with 20 percent or less in and slowly use the arrow keys beside the fire button power settings to drop the percentage until the laser disappears, or you can start at zero and slowly increase until the laser just appears and use whatever percentage you get in this test as your min power setting. Your looking for the percentage where your laser just turns on there will be a range from maybe 0 to 5 percent or something where the laser has no output. This is different on my laser since i can fire mine at 0.25 percent and still get an output, yours will certainly have a dead zone from zero to its min.

Just curious. Savings the project to the controller or running directly from the laptop?

1 Like

That’s just not true. The laser isn’t ‘powered down’ between vectors, it’s turned off.

You don’t understand max/min settings. I would suggest reading the docs.

Max/min is used to compensate for ‘cornering’. Usually only a percent or two.

When the laser traverses a sharp corner, the time the beam spends over the material is increased and you can get burn-through where you don’t want it, or fail to burn through where you do.

The previous reply to your post was incorrect.

1 Like

I would make sure to ‘send’ rather than ‘start’ a job and see if the problem goes away.

Also invest in a good-quality USB cable with chokes.

The problem you are seeing is typical of a misread file. Rudia USB implementation is primitive - USB 1.0 - very slow, almost no error correction.

This is a cable with chokes: They are the lumpy bits at both ends :slight_smile:

41+KqVDW34L.AC

Cheap/bad cables and a too-high transfer rate.

Cut your transmission speed, or invest in better cables.

Please enlighten me further if I am wrong, if the laser is set at 20 percent when LB is telling it to be zero, and 20 percent is enough to mark the material would it not just be on at 20 percent when it travels?

My understanding is that min should be set to just turn on a CO2 laser which is likely going to by way under 20 percent. The video in my reply does explain how to setup the min.

Hi, thanks for taking the time to respond! So I typically send the file and then hit start. I have tried hitting start from the controller and from lightburn itself. As for the usb cable, I have the one that came with the machine. It does look like yours and has the chokes but could it be that it’s just a faulty usb cord?

When you ‘start’ from LB, it sends and starts the job in one go. If you’re having issues, best to send it, then start from the panel.

I would definitely try another cable. Monoprice has good ones at reasonable prices.

1 Like

You are wrong - read the docs on power setting.

Your understanding is incorrect.

A couple things, can you provide me a link to the power settings section of the docs you are referring to, I can’t find a section for that and really do want to read it. Are you saying there is no need whatsoever to actually test and find the proper min power setting for a CO2 laser?

And no, that’s not what I was saying

Thanks for the cut and paste I can say that is right for cutting but min power does play a role when doing grayscale images here is a link from another post. I am just trying to point out that my original response was not wrong, min power should be set properly and it is used in grayscale. Perhaps its not the cause of the random lines in this post but its a good start for the poster to set it right and try burning again to see if the issue goes away.

https://forum.lightburnsoftware.com/t/grayscale-engravings-very-light/11181/4?u=renegade1966

Hello Bo,

I already thought about the bad quality USB and tested something to be sure :
Instead of running the job in LightBurn, I just exported the Gcode, directly in my Spark xPRO v5 controller (this ESP32 has a SDCard were I can put my gcode directly), and launched this gcode directly from the GRBL webUI. Doing so, I totally exclude a transmission problem that could appear between Lightburn/computer and the GRBL board.

=> Results are the same : I still have unwanted lines (thous lines appears sometimes between 2 burned zone, sometimes in the overscan zone.

So the problem isn’t coming from LightBurn, neither from the USB cable. It could then come from :

  • The laser PWM input (NEJE 40W laser) : is maybe unstable ?
  • The NEJE switch (witch interface the GRBL Board PWM output with the Laser PWM input) : is maybe unstable ?
  • The GRBL Controller PWM output (Spark xPRO V5, ESP32)) : is maybe unstable ?
  • A problem with a wrong parameter somwhere in my GRBL controller ?
  • A compatibility problem of the PWM output and the NEJE module/laser input (voltage or frequency threshods)?
  • Electrical interferences on PWM wires between GRBL controller and the laser ?

Another strange thing, I only noticed lines that shouldn’t be burned, but never lines that should be burned but are not. Like if the laser might forget to turn off, but never forgets to turn on ? Or maybe is it just more difficult to notice ?

Any ideas ?

1 Like

Stephanie you sound much more experience than I do, I am not sure what most of that means but if you find a solution or any helpful info can you let me know and I’ll do the same for you?