Random lines engraving that shouldn’t

Curious if the problem was solved for you.

I did some more testing with the latest version and have boiled the errors down to running the job from the PC.
If I run the job from the PC I get random lines and/or shifts… If I run the same job from the controller its perfect…

My cable is original with the chokes and the PC is more than capable. Not sure where the error happens.

I haven’t downloaded the new version because I’m having some trouble accessing my lightburn account on my new laptop. I gotta get it off the old laptop first. As soon as i get it together I will try the new version!

You can use the License Portal to help you with this. Self-serve tool to help you with the allocation of your seats. :slight_smile:

I’ve held off updating until after Fathers day (in Aus) - too busy at the moment to risk any issues.

I’ve updated my desktop pc, where I do some of the design work, but not my laptop.
I’m still using .lbrn format as I know it works for me.

We have an update patch that I’ll be trying to release in the next couple of days that may help all of this. I discovered a bug in MacOS / Big Sur (possibly others) that breaks what’s called ‘flow control’ between the computer and the Ruida.

If the computer sends data too fast, the Ruida can send a signal to make the PC pause the sending while it catches up. On the Mac, this signal was being ignored. Recent changes to the serial code in LightBurn have made it more efficient, and therefore faster, making it more likely that this will be a problem. I’ve added some internal rate throttling to make sure that the transmission rate stays within a safe limit for the Ruida USB, and it’s working on all the machines I have available to test, as well as a few users who’ve reported back so far.

I’m hoping to release this tomorrow or Tuesday, assuming the incoming storm doesn’t knock out our power.


I just had this happen last night with the latest version….using windows 10 on a ruida controller. Very rarely occurs but when it does it can ruin a job. I see it happen mostly on large files and if the laser runs as soon as enough buffer has occurred. Definitely still happening.
Now correct me if I am wrong but wasn’t there a way to send it and not have the laser start on its own until the entire file is sent. Not talking about send as that requires then going to the ruida to start and choose the file.

Hold Shift when you click send. LightBurn will send the job as a named file, but will also auto-start it for you if the transfer succeeds. You will still have the file in the controller, so you’ll need to clean them out occasionally.

That was it thanks

I havent been able to try it to give you an answer because I’m having issues with my lightburn purchase. I bought a new computer cause the old one was so slow and wanted to remove lightburn from the old and add to the new but something odd is going on. I wasn’t able to and when I reached out to lightburn i was told that someone else had the same access key, so somehow the key get issues twice? I don’t know, I’m trying to straighten it out now. In the meantime, i haven’t tried the new version. Hopefully I can soon!

If you can’t use the key, send us an email (support@lightburnsoftware) with your trial ID and we can extend that while you’re getting the key issue sorted.

Hi. I am having these same issues. How can I also get the patch? Did it work?

Was this issue ever resolved? I am having the same issues.

I’d like to confirm his as well. Happens rarely (like maybe once in two months, where we cut daily), can’t pinpoint any specific pattern. We’re not tracing/greyscale engraving or antyhing, just engraving and cutting simple vector shapes and text. It happened both with imported files or vectors made directly in lighburn.The lines are very faint but visible.

I’m having this exact problem and can’t figure out

Hello, I’m having same issue. Did you ever get fixed?