Random movement

i need help with my machine i am using Grbl 1.1 on a Two trees machine it homes correctly but the show laser position does not track correctly sometimes it even moves opposite direction from the laser. i also notice that if i make changes to a job and i send it to the laser it does not register the changes. sometimes it moves randomly.

What does this mean? Can you provide an example?

Where does the laser home and where do you have the ‘Machine Origin’ set in the ‘Device Settings’ window? Common Grbl Setups - LightBurn Software Documentation

What kind of changes, when and what do you mean, exactly, when you say, “…it does not register the changes.”?

thanks for the help. when i push the show laser position it shows me a random position on the screen and it does not move with the laser it just gets stuck in the same place sometimes it even moves around on its own. it used to work fine and i would use it to position my material in the right place. it homes to the top left corner and i have it set to the top left corner. if i need to make the a object bigger and i make that change the laser will not register the changes and it will make it the original size or if i need to move a object from its original location the laser will not pick that up and will burn that object in the original place it was in.

In the “Short Version” of the document I provided, it states,

  • Set your machine status reporting to be relative to the workspace origin, not the machine origin ($10=0).

  • Make sure the controller is reporting positions in mm, as expected by LightBurn ($13=0)

When you reviewed this document, did you make these changes? What was the result? Please try to be as clear and complete as you can be. I know this is obvious, but we are doing this remotly, and can not observe what you see unless you tell us exactly what is or is not happening.

The following is from our Documentation on the Device Settings page: Device Settings - LightBurn Software Documentation

Origin

This is the origin corner or 0,0 location for your laser. If you have a GCode based system, this is almost always at the front left, regardless of the location of your limit switches.

You will need to make that change as well.

Do these things and report back, we can go from there.

Thank You Very Much

Thank you that helped

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.