Random offset occurring


(Rick) #1

Just purchased LB, I had only used the trial for a bit, I would also get confused with the origin stuff since I don’t have homing on my laser. Still getting used to it, but I did notice that sometimes it seems to get an offset when running the same job. After I purchase it yesterday I was doing a test on a raster image and when I would stop the job and try to do it again, the position would move. I figured it was something I was doing wrong with the origin options. So today I was testing again with a simple circle and the offset happened without changing anything. I ran the job the first time and it completes as expected. Drew another circle at different position, job completes and the laser movers back to where the original circle is located. Ran the first job again and got the offset. Tried it a couple of times, it only happened twice, but now the laser stutters a bit when I start the job like its auto correcting itself I guess. I’m just trying to figure out how can I prevent this from happening in case I’m doing a job and have to stop and restart for whatever reason and make sure it doesn’t offset again.


(Colton McClure) #2

Had the same thing happen today twice. Finished the job and then the laser head moved to a position about 1/2" to the right of my origin. Hit ESC hoping it would go to the original origin but it was already set to the offset position. (Origin is set to the top right corner for reference)


(Oz) #3

You said you don’t have homing on your laser, so how does the machine know where the origin is? You’ve also indicated that your machine is a “DIY grbl” - have you run enough jobs in the past to know that it’s tuned properly and the motors aren’t missing steps?


(Oz) #4

Colton - I’m assuming you’re using a Ruida controller (your profile and post don’t say) but the OP isn’t, so his controller doesn’t have an ESC key.


(Colton McClure) #5

Correct, Rudia. Only mentioned the esc key as a way to return to my origin. I reran the same RD file saved in the machine and it did it again… so now my origin is about 1" from where I started. Note: I do not use LB connected directly to the machine, I transfer via USB, and use “User Origin”. I did a similar job Friday and did not have this issue, do not believe I have adjusted anything since I created the laser settings for this job that same Friday. Been using RDworks on this machine since 2015 and have never encountered this.


(Rick) #6

setting it to absolute coordinates fixed it for me so far


(Colton McClure) #7

We use separate files for fixture jigs and engraving runs. We secure a cardboard sheet, set our origin, run our fixture file, insert fixture or part into cutout, adjust focus height, and run engraving file. Being that we do not have a computer connected to our machine, absolute coordinates would not work well for us.


(Oz) #8

If you cut the jig itself with absolute coordinates, and the jig is placed in the machine in the same place every time (for example, butting against a corner of the honeycomb or frame) then you’d never have to align the laser to the jig. I use this method myself.


(Colton McClure) #9

That doesn’t solve the problem. Something in the software output code is offsetting the origin at the end of the run. Didn’t have this issue Friday and now I do this week. Band aiding the situation does not fix the issue.


(Oz) #10

I wasn’t suggesting it would, just thinking it would save you some effort in the future.

Nothing in the software has changed in the time frame you mention - have you changed any settings? Check to see if you have an offset entered in the device settings, here:

image


(Ricardo Lopes) #11

I have exacly the same issue. It does not happen in all the projects, but happens.
After 3 job attempts failed, and review all the machine settings, belt, motor steps, I realize that was a bug introduced by software/firmware.
Ligth Burn version: 0.9.04 (happens with 0.9.02 also)
Board Firmware: Smothieware (general 3/03/2019 version)

What I discovered so far:

  • Only happens with specific project files
  • Using “Start From Current Position” option.

How to reproduce:

  • Boot the system
  • Home the system
  • Move the head to any coordinate
  • Hit “Get Position” and remember the x, y coordinates
  • Select the option “Start From: Current Position”
  • Start the job (you dont need to have the laser actually firing, only the head moving arount)
  • After the job ends, hit the “Get position” again, and you will notice an offset from the coordinates recorded before the job starts.

Since this not happen with all the projects, I sent a LB project file to support email.

CONSOLE OUTPUT:
ok
<Idle|MPos:0.0000,0.0000,0.0000|WPos:0.0000,0.0000,0.0000|F:4000.0,100.0>
Starting stream
Stream completed in 1:58
ok
<Idle|MPos:0.0898,-1.2408,0.0000|WPos:0.0898,-1.2408,0.0000|F:2400.0,100.0>

Important Note: Today I update the board firmware with the CNC version, and looks that this error does not happens!

The picture shows an example. One job run, two passes.


(system) closed #12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.