Random Wiggles, Bent Lines, and Deformities


I recently updated a 400mmx400mm Golden Laser 50W Chinese laser cutter with a Ruida 6442S, updated drivers, and Lightburn. When I cut small jobs or or a small number of jobs, everything is fine. However, if I try to cut multiple parts, even if they are identical, in the same job; I am get engraved lines that are not straight on part of the piece. Identical parts also seem to have the same error. This is not slippage, and doesn’t change with speed or machine acceleration. I have also tried connecting via USB, ethernet, and sending the file to controller before cutting. The problem also seems to be random, but once an element is cut wrong the machine repeats the same error within a job. I have attached a picture of the issue. Incorrect lines are marked in red, and correct one are marked in blue.

Any help would be greatly appreciated.


That says it’s skipping - either mechanical or electronic.

Do you have a separate power supply for your steppers and controller?

The ideal setup is ~20KV Laser PSU, 40V stepper PSU and 24V controller PSU, with maybe a small 5V PSU for ancillaries.

Yes, I have separate power supplies for the controller and steppers. Starting to think I am losing data somewhere. Think using a USB stick will help?

It can’t hurt. But the fact that the problem persists after it goes wrong indicates slippage, of some sort - mechanical or electronic.

With the power off, you should be able to freely move the gantry in x and y, with little resistance. Try micro movements back and forth in both axes to diagnose mechanical slop. Listen to hear if your mirrors or lens are rattling.

Check ground on all devices - stepper drivers, controller, switches, mA meter, and check ground between the chassis and centre-pin of your AC supply.

Thanks, I will try all of that tomorrow.

1 Like

I tightened the belts, and that seems to have fixed it. Its a new laser with less than 50 hours of use, so I never thought that would be an issue. With the old M2 nano, it had mechanical skips at the motors due to the low (5V) power being delivered to them. I guess the belts were never fully adjusted at the factory because the motors had issues before they slipped.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.