Raspberry Pi lost connection

Hello All,

I’ve been using my Thunder laser with a Raspberry Pi bridge and ethernet connection since the beginning of this year without major issues. Occasionally I’ll lose connection but a reboot of the Raspberry Pi or hitting the ESC key on my laser always worked as way to reestablish my connection.

Yesterday, I needed to move my laser to a different spot in my shop which meant I was too far away from my electrical outlet and so I purchased a longer CAT 6 cable to allow me to power up the Pi. I immediately ran a test by sending a new file to the Ruida controller and was able to confirm my connection was good and the file transfer was successful.

Today, no amount of fiddling is working to get connected. I’ve tried rebooting the Pi, rebooting my router, rebooting my MacBook Pro, deleting previous devices and manually resetting and powering off and on my laser. Re-scan comes back empty.

Any suggestions or advice to help me connect would be greatly appreciated.

All Raspberry Pi boards seem remarkably sensitive to bad power, so I’d power it with a known-good wall wart (*) at the laser, rather than from PoE or just stuffing 5 V into a long cable.

Power problems produce all manner of intermittent failures with bizarre symptoms, so rule that out first.

(*) Something like 5 V / 2 A, rather than a random phone charger. If it had a UL listing, that would be gravy on top …

Not a techie here so unsure of what you’re suggesting. If you mean the quality of my new Ethernet cable is suspect, I understand. Specs claim Cat 6, UTP, 24 AWG, 35 feet long.

I switched back to the original Cat 6 cable and used a power extension cord instead hoping to eliminate the Cat 6 cable from the equation (not the solution I’m hoping for). Still no luck connecting.

I misunderstood, thinking the Pi drew power though the (new) Ethernet cable. If it’s (still) powered through the wall wart that came with the Bridge package, then the whole power issue Goes Away.

At this point it’s down to network connectivity debugging, for which I have little to offer. [sigh]

So barring the physical move you’re back to the identical hardware+cable setup that was working previously? Have you tried an external power supply? Does the Pi pop up on your network if you use a tool like Fing or from your Router’s UI? It may have been assigned a new IP.

Yes, with the exception of having to use a power cord extension to reach the power outlet, I have switched back to the original Cat 6 cable. Not sure what you mean by “external power supply” but it is currently connected to the same 20A wall outlet I’ve always used.

The Pi does not appear on my list of available networks. Nor does a rescan from the LightBurn control panel recognize any Bridge device.

Like I mentioned in my original post, I tested the Pi immediately upon reconnecting at the new laser location and was able to connect, transfer files and confirm that it was good to go (even with the new Cat 6 extended cable). There was no need to check the router’s UI at the time so I can’t say if for sure.

Just to confirm I’m doing this correctly, when trying to connect manually, when LightBurn asks for the IP Address of the device, it’s referring to the laser IP (which is, correct?

Still can’t connect in spite of my best efforts.

I have successfully connected via the USB port. No problem.

Rebooted the Pi several times. All flashing lights appear to be functioning normally. Green light on back of Pi is lit and red light on front also lit.

Any suggestions for other troubleshooting procedures I might wanna try? Lemme know. TIA.

If you can’t see it on your network, you won’t be able to connect.

What tools do you have for scanning a network?

I use arp-scan, it’s available for the mac.

jack@Kilo:~$ sudo arp-scan
Interface: enp2s0, type: EN10MB, MAC: 74:d4:35:1b:74:68, IPv4:
Starting arp-scan 1.9.7 with 256 hosts (https://github.com/royhills/arp-scan)	c4:41:1e:ae:7a:e6	Belkin International Inc.	00:21:b7:8e:15:2b	LEXMARK INTERNATIONAL, INC.	8c:49:62:61:1a:45	Roku, Inc	e4:5f:01:97:20:8b	(Unknown)	88:66:5a:4a:cb:3a	(Unknown)

5 packets received by filter, 0 packets dropped by kernel
Ending arp-scan 1.9.7: 256 hosts scanned in 1.972 seconds (129.82 hosts/sec). 5 responded

I know the Pi has an ending mac address of 20:8b…

If you don’t setup your router to handle an ‘ip renewal’ the order of ip addresses can change and you have to edit that for the ‘device’. Most have some way to reserve or ‘bind’ an ip address with a mac address, which eliminates the issue.

Good luck


Okay. So I downloaded LanScan and got this result. No idea what I’m doing or what this means. Am I on track here? I don’t see anything ending in mac address of 20:8b.

So, I just rebooted the Pi again and this time it showed up on the LanScan. No idea what this means or wha to do next. Please advise…

In Lightburn in the laser window, click devices and then select the ‘lightburn bridge’ and add it manually. The IP address will be required.

What used to happen with mine, is the ip would be refreshed and it had a different IP… Had to change it every time. Bond it to the mac address, not an issue anymore.

You can right-click on the devices button to re-connect…


I’m back up and running! Thank you Jack, for all your help!

No idea what you mean when you reference “Bond it to the mac address” however. Is it complicated to do? Sounds like it would save having to reenter the IP address at every start up.

IP addresses need to be re-fleshed depending on their ‘Client Lease time’, as set in your local network. Mine is set for 1440 minutes, I think that’s 24 hours. When that happens, rebooted or power fail, it goes through the devices and they are generally sequentially assigned. So if something isn’t on-line when the power comes up, it can end up with a different ip.

My router shows a ‘network’ map, and you can just click on the device and the option is to make a reservation. However you can go into the lan area and it has something you can ‘reserve’ the devices dns… This is ‘binding’, I must have typo’d it…

This is based on the MAC address…

Good luck