RDC6442G no longer connects over ethernet

I had been using Lightburn over the Ethernet with a Ruida controller for about a day. The next day, lightburn displayed “disconnected”

I tried a few different IP addresses, I have remade the device entry, I have edited existing entries. I have restarted lightburn,
I can ping the laser and RDWorks will connect and control the laser.

Power down the Ruida then go to a command line and ping the IP#. It should not get a response.

If it DOES, then another device on the network is occupying that IP#. This will prevent the Ruida from working. This could be because the other device has a static IP# in its config that is the same as the laser, or the router does the standard DHCP and sometimes dynamically allocates the IP# that the laser uses to this other device because it didn’t know to reserve that IP#. This can be an intermittent problem that sometimes happens and sometimes goes away when rebooting the network.

If so you need to change Ruida’s static IP#, the other device’s config, or router config.

1 Like

I use ‘arp-scan’ to return all the devices on the local network. I can see the Ruida or the bridge depending on how I’ve got it set up.


jack@Kilo:~$ sudo arp-scan 192.168.1.1/24
Interface: enp2s0, type: EN10MB, MAC: 74:d4:35:1b:74:68, IPv4: 192.168.1.112
WARNING: host part of 192.168.1.1/24 is non-zero
Starting arp-scan 1.9.7 with 256 hosts (https://github.com/royhills/arp-scan)
192.168.1.1	    90:c7:92:05:83:07	ARRIS Group, Inc.
192.168.1.12	00:21:b7:8e:15:2b	LEXMARK INTERNATIONAL, INC.
192.168.1.110	a4:38:cc:90:e1:ab	Nintendo Co.,Ltd
192.168.1.106	04:c9:d9:e5:97:0b	Dish Technologies Corp
192.168.1.115	04:c9:d9:e5:97:0b	Dish Technologies Corp
192.168.1.100	d8:31:34:f7:76:44	Roku, Inc
192.168.1.101	8c:49:62:61:1a:45	Roku, Inc
192.168.1.105	04:c9:d9:e5:97:0b	Dish Technologies Corp
192.168.1.108	88:66:5a:4a:cb:3a	(Unknown)
192.168.1.120	84:4b:f5:52:12:d0	Hon Hai Precision Ind. Co.,Ltd.
192.168.1.114	b8:27:eb:0b:0f:9d	Raspberry Pi Foundation

14 packets received by filter, 0 packets dropped by kernel
Ending arp-scan 1.9.7: 256 hosts scanned in 1.977 seconds (129.49 hosts/sec). 11 responded
jack@Kilo:~$ 

The Raspberry Pi Foundation’ is the Lightburn Bridge…


If you can handle changing IP addresses on your Ethernet port, you can go directly from the Ruida to your PC. I set my pc’s IP to the Ruida ‘Gateway’ and then the Ruida is available…

Good luck

:smile_cat:

No response with the Ruida off or disconnected. I tried a few different IP addresses in case this was the issue.

I can see the ruida from my router:

MAC Address 02:a0:c9:78:3e:96
IPv4 Address / Name 192.168.1.150 / unknown02a0c9783e96
Last Activity Tue May 17 19:08:56 2022
Status on
Allocation static
Connection Type Ethernet LAN-2
Mesh Client No

It reads as status off when I turn it off

I will try the direct connection trick if no solution is evident, but I cant really have a dedicated connection just for that,

Thanks

Have you tried a new cable?

Sounds like it’s working.


No reason to go direct, just useful to ‘check’ out things.


I suggest, going back to the original IP you were using on the local net. If you can ping the device, it’s talking. It has to ‘connect’ to return the ping.

Ensure the device configuration is the proper address. Looks like it’s there from your post.

Also ensure the Ruida is in an idle condition. It’s supposed to be in that configuration after a successful boot.


The only other item that isn’t intuitively obvious is you can ‘right click’ on the device button and it will attempt to ‘re connect’.

Good luck

:smile_cat:

For future googlers, I restarted my computer and the problem went away. not sure what the cause was.