RDC6445G Y axis limits staying on

I’m building a 90w laser, based around the popular ‘Further Fabrications’ design with a Ruida RDC6445G.

I installed Home and Limit switches on all three axes, which did work fine. But now, the Y axis limits are showing as permanently ON, on the RDC6445G diagnostics. And now I cannot jog the Y axis, which I assume is due to the limits staying on. I cannot get these to clear, even if I unplug the connectors from the main board. After installing all six switches, they worked fine but I seem to recall the Y axis lightly crashing in to one of the switches, and probably why they are now permanently on.

Any ideas on how to solve this?

You can disable limits within the Ruida itself… just turn them off…

If you pull the connector, that should indicate a non active state… if it shows up in the Z/U → Diagnosis screen, you’ve likely got an issue with the Ruida… especially since it was working.

Are these active low switches…?

Did you check them with a meter?


Thanks for the reply Jack.

The switches are active low, just simple lever micro-switch type. I appreciate that I can disable them but I need the function. I also checked them with a meter, prior to adding them to the controller.

You’re going to have to ensure the controller is attempting a home operation on boot…

It’s possible that the machine is configured this way, but I don’t know if/how to do this…

If you unplug these switches (connector to the Ruida) it should isolate the issue between the switches and the controller… they should go inactive with the connector removed…

It has internal pull ups, so it should go inactive… does it?


Having powered everything down this morning and booted up, the machine tries to do a home sequence but fails on the Y axis. I reconnected the Limit plugs and interestingly…although the diagnostics show the Y limits are ON, now when I press the switches, the (diagnostic) 'LED’s go out (as if they were active high). It didn’t do this yesterday, they just stayed on constantly. I’ll do a bit more investigation today.

I did wonder if a Reset to Factory Defaults would solve the issue but it asks for a password, and it’s not the usual RD8888. So, on a side note, do you know what this password is? I have not set any any other passwords. The manual isn’t the best at describing this function.

Well…I’ve managed to do a factory reset and it seemed to solve it.

Generally factory resets of a Ruida are not recommended.

You have to ensure you have saved and restore the original manufacturers configuration for the Ruida…

Glad you have it worked out…

Take care


Thanks Jack.

This is a new-build, and I’ve just got the mechanics side of things completed. I’m not too far in the build yet, so I didn’t have any saved settings to worry about (although I do now).

As you can tell, I’m pretty new to lasers, although familiar with CNC’s, having built a desktop milling machine and converted a couple of woodworking machines to touch-screen control using Mach3 and more recently UCCNC.

Thanks for the advice and I’m sure I’ll be posting more questions in the near future!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.