Rectangles inside other shapes have radius corners :?

I’ve never noticed this before, but rectangles drawn inside of another shape have radius corners when viewed in the cut preview window. That’s a problem assuming it will actually cut that way. It also only seems to occur if the layer is in Line mode. How do I prevent the radius corners in this case ?

LB 0.9.20

I can not reproduce the error you describe, can you show a screenshot?

Not seeing it here either.

You probably have a kerf applied to that layer, which would offset the cutting path.

1 Like

Oz, yes I have a kerf offset of -1mm. But why is it affecting only every other interior rectangle ? And negative kerf offset affects the alternate set of rectangles vs. positive offset.

Is there anyway to prevent the behavior other than zero offset and I compensate for kerf by making the rectangle larger or smaller ? I expect to have this condition of rectangles inside of shapes quite often when plasma cutting soon.


for those interested, here is pic of preview, and layer settings.

It’s not a bug, it’s absolutely intentional.

The correct path for a round cutting tool, offset along the outside of a rectangle, is a rounded rectangle. In the image below, black is the rectangle, green is the tool diameter, and the red line is the resulting cut path:


The reason it alternates is that every other nested rectangle flips from being “inside” to “outside”, for exactly the same reason that the lead in flips to the other side. It’s possible to not round the corners on outside offsets, but they have no effect at all on the resulting cut shape (if you specified the offset correctly), and they produce less jarring direction changes, so they’re preferable for the machine.

1 Like

Got it. thanks for the explanation. Good to see it has no effect on the resulting cut (saved) shape. Very Good.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.