Red and Black 60W laser, lightburn won't recognise it

It’s a new setup. the computer tones when it’s plugged in but no connection read.

Check in Device manager to see if the driver for the USB Serial is loading correctly in windows, i had a very similar issue and had to install the driver manually.

On the last page of the LightBurn installer there’s a check box for the FTDI driver. Re-run it, and check that, and that should work.

I reinstalled the software and checked the FTDI box. that didn’t work either. the RDWorksV8 software that came with the laser hooked up and works fine. I bought the Lighburn software to use with the Lightburn camera. and for easier operation.

Do you have a Ruida motion controller?

I have a red and black Chinese 60 watt with the ruida control.

This sounds silly, but restart the computer and have another go. When you say “LightBurn won’t recognize it” what steps are you taking to connect to it? Is this the automatic device search that’s not working?

Is it telling you that you have the wrong license type, by chance? I’ve looked up your key, and you have a GCode key. If the auto-search says it found a DSP laser but you have a GCode key, that would be the problem - you’d need to upgrade the key to a DSP key.

I did a reinstall, restarted and the search. When the search starts the search screen looks then there’s a flash of another window just for an instant you see a green bar then it’s gone and the window with the device found is empty. It’s not showing gcode or dsp. I am using a windows 10 computer with both my ortur and the red and black could there be a conflict? Should I delete the ortur gcode device totally? I have another laptop to use with it.

The issue, as Oz pointed out, is you may be using a key that does not support your DSP laser.

Did you visit our web store and purchase the upgrade to the DSP version? LightBurn Software - Upgrade from GCode to DSP license

It’s not saying anything the screen comes back with an empty window.

I do not understand your response.

  • What is “not saying anything”?
  • What “screen comes back with an empty window”?

Please provide greater details as to what you did, where you tried to do it, and what was the result.

To answer your exact questions. I open lightburn. I press the “Devices” button. I then press the “Find My Laser” button. The “Be sure your device is connected via USB, and click next” appears, i made sure it was, and clicked “Next”. A small window appears which says “Lightburn 0.9.22” it’s on for 12 seconds and then disappears. The window still remaining on the screen says “Device info” “Type” and nothing else is displayed! The buttons at the bottom of that window are “go back” and “cancel”, “Add device” is grayed out.

this all I get. The “RDWorksV8” that came with the laser works great, but not the lightburn software with the lightburn camera.

Understood, so thank you for that. I am seeing 2 issues. First, the ‘Find’ should have presented a message finding your controller but also identifying you need to upgrade to add this type of laser system. This did not work as we’d expect, but that is a minor issue, as we can always add your device manually. We will get there.

The second issue is a license issue. Not wanting to come across as a jerk, but you are not following what we are trying to tell you.

You are trying to talk to a DSP controller, but you do not have the correct license to do so.

LightBurn looked into our systems to find you currently have a GCode version and will need to upgrade this key to provide DSP support before you can add and connect to your Ruida controlled laser.

I just looked again to find you have not upgraded, so you will not be able to use LightBurn with this laser until you do so.

I’ll get the upgrade this afternoon.

I think that’s been processed now. The next part, the not finding the laser, is a little more strange, though it’s possible it’s because of the issues we’re having with 0.9.22. I’ll try doing a device discovery right now with a clean setup and my latest code. If that works, I’ll get you a link. We’re still running tests, but so far it looks like things are stable again.

1 Like

One other thing that can cause problems - If you have a device configured for GRBL, and it happens to see the Ruida controller serial connection, it can try to connect to it, and that will prevent the Find my Laser tool from being able to talk to it instead.

A way around that is to plug in the GRBL device too, and choose the right COM port for it first so you can see it talking in the console, THEN click the devices button and try to find the Ruida, also connected to the computer with a different USB port. It’s just because they’re both using serial connections, and GRBL is so generic, and sometimes uses the same USB comms chip that Ruida does, so it’s not easy for us to tell them apart just from the port type.

That’s actually likely what’s happening here - I tried it on my own system with a GRBL device chosen, and that’s what happened. Then I just picked the right COM port for GRBL instead of letting it auto-choose, and then the device search worked.

Doing a ‘Create Manually’ would also work - you’d just have to enter Ruida, Packet/USB, the size, pick an origin, and that will work.

I sure don’t like being a pain in the *** but I didn’t get a link or anyway to update my software in the notification email? Did I miss something?

Well, I read your email, about the possible conflict and deleted the GRBL altogether for now and the program found the RUIDA immediately! it seems to be working fine.

Others have. :slight_smile:

Glad to hear you are sorted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.