Regular interval gaps using diy rotary chuck

Have a DIY rotary Chuck that I am using with the Comgrow Z1 20 watt Laser. I am getting evenly spaced blank spaces no matter what I do. Stepper motor is Stepperonline Nema 17 Stepper, step angle 1.8 deg. 200 step/revelution. As far as I can tell it is the same type stepper as the comgrow stepper but larger.
this is what I have tried

  1. checked that mm/revolution is correct
  2. Calibrated both X and Y axis
  3. re-focused both up and down from 8mm
  4. not an image, graphic set to fill
  5. Not an image so pass through not an issue
  6. does same when set to 0 or 90 degrees
    sure would like to resolve this

Have you checked your “line interval” under “common settings” in the cut settings editor ? Typical setting would be .1- .2 mm or something around that.

A photo is worth > 1k words… :wink:

:smile_cat:

1 Like

If it has a belt drive between the motor and the chuck, check for a bit of crud jammed in one tooth of either pulley. The crud will cause a periodic glitch as the belt stretches over it.

If it’s direct drive, using a very low microstep ratio (a.k.a. “pulse/rev” on the stepper driver brick) can interact with the scanning line interval to produce a Moiré pattern, because the line interval requires a scan at a position the stepper cannot resolve. The symptom will be a gap with a misplaced scan on one side.

Perhaps less crud or more steps will get it moving properly …

2 Likes

This is great. Please post a pic.

How far apart are the evenly spaced blank lines? It’s possible that it’s a rounding error related to line interval but that would be a longshot. Adjusting line interval by 10% would move the blank lines and let us know if we’re on track.

Great test! The repeated blank lines won’t change if this behavior is Crud-driven. :slight_smile:

Please wiggle the chuck clockwise and counter clockwise to see if there’s some backlash or a loose screw in the mechanism.

Is there a heavy handle on the target / object in the chuck?

There is also the possibility that the Step Idle Delay setting ($1) isn’t leaving the motor windings powered for long enough (or full time). If there’s a heavy handle and enough motor-off time the motor could periodically slip a small amount at one of the weaker micro-steps.

In LightBurn please request the Machine Settings by typing the following into the Console window:
$$
then press Enter.

I don’t need to see them just now, please make a note of the number assigned to $1= (toward the beginning of that report).

In the Console window in LightBurn, type:
$1=255
then press Enter.

Please re-test your project on a scrap or damaged sample until we can figure out what happened.

If the revised setting doesn’t solve the repetition and missing line please set the $1 setting back to what it was.

with $1=255 get same results.
direct drive no belts
chuck does not wiggle

A screenshot of the cut/layer edit screen so we can see the values.

:smile_cat:

it is not belt driven and not sure where “pulse/rev” is changed.
in rotary set up it is "mm per revolution

saved a blown up preview and it looks like this

I have tried from 180 to 600 still there

Ah. Forgot you were hacking this into a Comgrow, where you don’t have that option. In bigger machines, the stepper motor driver will have a DIP switch or jumper block for that value: it’s the number of pulses from the controller required to turn the motor one revolution.

In your machine, the GRBL $100 and $101 parameters give the number of steps required to move the X and Y axes 1 mm.

Then the mm/rev value is how LightBurn maps the linear distance of the pattern to be engraved to the circumference of the mug / tumbler / sippy cup in the chuck. Knowing the distance around the mug, LightBurn & GRBL can convert that into the number of pulses required to turn the mug exactly once.

I’ll fade into the background, as it looks like other folks who know more than I do have arrived. :grin:

today I replaced the stepper motor with one that is supposed to be a direct replacement for one of the Y-AXIS stepper motors. Same thing. i have tried everything everyone has suggested and then some. Possibly there is no answer

What stepper driver are you using for the new motor? Have you configured your dip settings correctly? what microstepping are you set at?

(EDIT) lol… it helps to read all the above answers. I did find a pcb shot of the mainboard for that laser. Indeed there are no outputs for an external driver board, nor any microstepping jumpers…unfortunately… So I have answered my own query. without hacking into pins on your board that isn’t an option.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.