Relative Z Issues with Ruida Controller

In 9.00 I am experiencing issues with the relative Z. I have a BOSS LS-2436 (Rudia) running Windows 10. I have crashed the head several times recently, and need to know what’s going on. Maybe it’s me, but I’ve been doing it one way for quite some time, so I’m not sure where I’m going wrong.

  • The z-offset in the layers is 0
  • The material thickness is set to Xmm.

It appears that lightburn doesn’t always get the correct z position sometimes?

In previous versions it used to be that I could autofocus the laser (it would be lets say 8.7mm). If the “material” thickness in lightburn was set to 0, then the laser would just run at this level. If I set the material thickness to 7mm, then the bed would move so that the laser head was 7mm away from the surface of the material. In v9.00, the laser might be at 7mm, but the bed moves up further crashing the head. Another time it just kept wanting to move down all the way before starting. The behavior is somewhat erratic, which makes me worried to do jobs without crashing the head.

If it can’t connect to the laser to get the current Z height it should give you a pop-up saying so, with the option to cancel. Is this not happening?

From what you’ve described, it’s quite possible that with an auto-focus system, since the Z is zero’d by using the focus probe, you don’t need to run in “relative” mode at all.

Nothing is popping up as far as I know.

What is “running in relative mode”? I still want to be able to offset X amount in the file. Is there a special setting somewhere where this relative mode is turned on or off or are you just speaking generically?

/edit: I see the relative mode. It’s off.


Okay, new thing happening for 9.00+.

It used to be when I would set 0mm in the material thickness that lightburn would just run wherever the laser was, but now it always goes back to the focus distance (in my case 8.7mm) at the beginning of the job. I have always had enable-z checked, but not relative-z. This behavior does not change when I enable relative-z. Do I have to go into settings and disable z-control entirely just to run where the laser is set to? (I like to manually adjust sometimes).

Relative mode should be the equivalent of running with Z disabled, as long as you don’t have Z offsets specified anywhere. Basic operation is like this:

  • With Z disabled, no Z moves are ever emitted, with the exception of the Z jogging buttons in the move panel

  • With Z enabled, relative mode off, the “Material (mm)” setting is the baseline height for the job. Your Z will move to that height initially, and other moves will be based on that.

  • With Z enabled, relative mode on, the “Material (mm)” setting is ignored and the current machine height is read from the controller and used instead, unless it cannot be read, in which case it falls back to the Material (mm) setting with a warning.

1 Like