Remove third party firmware from Ruida

I have a CamFive laser that I would like to use LB with. Although LB works fine to move the print head around, I didn’t think to check whether LB can send files to the printer. I just put a .rd file onto a thumb drive and connected it to the CamFive and it didn’t read any of the files.

The Camfive has a Ruida 6442(S) in it, and I know for a fact that works with LB. But clearly, the manufacturer put a slightly different version of their own firmware on there. This makes sense in hindsight since they have their own laser cutter program called SmartCarve to use on a computer. They also use their own file extension to send cuts to the printer.

Is there a way to remove this firmware from the Camfive and revert it back to stock Ruida firmware?
Or perhaps I am missing an easier way to do it.

Thanks in advance!

Are you using the free trial or an existing purchased copy? If you have a copy you’re using, it must have a dsp license associated with it or it won’t talk to the Ruida.


If you a dsp license or you’re still under the trial version, I’d suggest trying to make a connection with Ethernet, not usb. If your home network works on your lan, then it should talk to the Ruida. There are no drivers involved, so they just work.

The only caveat is that the Ruida is a static device and is a fixed or static IP… You might need to bind the Ruida IP to it’s mac address. If you’re up on Ethernet communications, you can run it directly off your pc, but it’s more complex.


There is literally no information about how the innards on these work… I don’t know how to upgrade one if you can’t communicate with it…

If it’s specifically setup so you can’t access it, a change of firmware may brick the device making it an expensive paper weight.

You could pickup one of the current versions of Ruida firmware, there is no other vendors and the hardware is proprietary. Can you tell us what version you are using? It should show up after a successful boot on the console. Have to watch it, it’s not visible for very long.

:smile_cat:

I ran a CamFive machine with their firmware for the Ruida on LightBurn for years. In fact, I was the first one that contacted Oz back in the day and helped get that particular controller talking to LightBurn. You should be able to connect LightBurn via either USB or Ethernet and have it work without any issues, no need to revert firmware to original Ruida firmware. Is there some reason you don’t connect directly to the machine like this, or was there some issue when you tried?

I was using the free trial version of LB. But that just recently expired. So I’ll purchase the full version soon. I forgot to check the connectivity while I had the full software. But I had a thumb drive with some .rd files on it that I generated using LB so I figured I would check to see if it works. I did not check it over ethernet, but judging by what @sutick says, I think that should work.

If I run into any issues, I will grab the version number.
As always, thanks for the help!

Steve,

This is great to hear. As I just mentioned to @jkwilborn I need to buy the license to do this testing, but it sounds like hooking it up over ethernet should work.

Thanks for the help.

If you’re using a current version of LightBurn, I believe in Help/License Management, there should be a button in there now to request an extension of your trial license.

If the trial is over, it won’t connect to the dsp via any means.

If you’re going to buy it anyway, discussion over it being trial or not is rather moot.

:smile_cat:

I got a license for LB. Sure enough, the files send just fine over Ethernet.

Thanks for the help!:grin:

1 Like

If you save to an RD file without connecting to the machine first, LightBurn just saves using the generic scramble key used by most controllers. The CamFive / SmartCarve machine uses a different scramble key, so you have to connect to the machine for LightBurn to figure that out.

From there you can still save to RD files or send directly to the machine, and both will work.

1 Like

To clarify,

A computer (and LB) has to be connected via USB to the controller. Then, when hitting the save button, it will work?

1 Like

Yes, exactly.